Cisco has issued a warning on a critical vulnerability in the Wireless LAN Controller (WLC) software.

The bug, traced as CVE-2022-20659, allows remote attackers to login to target devices via the management interface without using a valid password.

The bug is exploited through the improper implementation of the password validation algorithm, which makes it possible to bypass the standard authentication procedure for non-default device configurations.

Products affected by the vulnerability are products running Cisco WLC software 8.10.151.0 or release 8.10.162.0 that have “macfilter radius compatibility” configured as “Other.” Products include 3504 Wireless Controller, 5520 Wireless Controller, 8540 Wireless Controller, Mobility Express, and Virtual Wireless Controller (vWLC).

Administrators can determine if their configuration is vulnerable by running the “show macfilter summary” command. If the RADIUS compatibility mode returns “Other,” you’re vulnerable to attacks.

To fix the bug, users are advised to apply the latest available security updates (8.10.171.0 or later) released by Cisco. This fixes the flaw irrespective of the configuration a user is using.