A pair of security vulnerabilities in a suite of tools used to send encrypted traffic to servers could allow attackers to run code of their choice on affected servers or cause denial of service attacks, according to a handful of security alerts released Wednesday.
The flaws exists in OpenSSH, a suite of tools that replaces such programs as Telnet and FTP (File Transfer Protocol) with secure versions, granting users an encrypted means of communicating with servers. Telnet and FTP are applications used to connect to servers, make changes to them and upload files, among other things.
The vulnerabilities affect OpenSSH versions 2.3.1p1 through 3.3, according to an advisory released Wednesday by the CERT Coordination Center (Computer Emergency Response Team/Coordination Center), a government-funded computer security body based at Pittsburgh’s Carnegie Mellon University. The flaws are in two different types of authentication modules in the software, according to CERT/CC.
An affected version of the software ship with the OpenBSD operating system. Users may have downloaded and installed affected versions for other platforms as well.
Users should upgrade to OpenSSH 3.4 or apply the patch available at http://www.openssh.com/txt/preauth.adv