<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"
	prefix="og: https://ogp.me/ns#" > <!--<![endif]-->
<head>
    
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.itworldcanada.com/xmlrpc.php" />
    
		<!-- All in One SEO 4.1.5.3 -->
		<title>Apache issues fifth patch this month to close another bug in Log4j | IT World Canada News</title>
		<meta name="description" content="More than one security researcher predicted the Log4j/Log4Shell vulnerabilities discovered before Christmas won&#039;t be the last. They were right. Apache has issued another security update for the logging library that administrators must now install in their applications. As of Tuesday the latest version of Log4j that should be in systems running Java 8 is 2.17.1. […]" />
		<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
		<link rel="canonical" href="https://www.itworldcanada.com/article/apache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j/469537" />
		<meta property="og:locale" content="en_US" />
		<meta property="og:site_name" content="IT World Canada - Information Technology news on products, services and issues for CIOs, IT managers and network admins" />
		<meta property="og:type" content="article" />
		<meta property="og:title" content="Apache issues fifth patch this month to close another bug in Log4j | IT World Canada News" />
		<meta property="og:description" content="More than one security researcher predicted the Log4j/Log4Shell vulnerabilities discovered before Christmas won&#039;t be the last. They were right. Apache has issued another security update for the logging library that administrators must now install in their applications. As of Tuesday the latest version of Log4j that should be in systems running Java 8 is 2.17.1. […]" />
		<meta property="og:url" content="https://www.itworldcanada.com/article/apache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j/469537" />
		<meta property="og:image" content="https://i.itworldcanada.com/wp-content/uploads/2014/11/INSIDE-SLIDE-hands-coding.jpg" />
		<meta property="og:image:secure_url" content="https://i.itworldcanada.com/wp-content/uploads/2014/11/INSIDE-SLIDE-hands-coding.jpg" />
		<meta property="og:image:width" content="420" />
		<meta property="og:image:height" content="280" />
		<meta property="article:published_time" content="2021-12-29T15:46:06+00:00" />
		<meta property="article:modified_time" content="2021-12-29T15:46:06+00:00" />
		<meta property="article:publisher" content="https://www.facebook.com/ITWorldCa" />
		<meta name="twitter:card" content="summary" />
		<meta name="twitter:site" content="@intent" />
		<meta name="twitter:domain" content="www.itworldcanada.com" />
		<meta name="twitter:title" content="Apache issues fifth patch this month to close another bug in Log4j | IT World Canada News" />
		<meta name="twitter:description" content="More than one security researcher predicted the Log4j/Log4Shell vulnerabilities discovered before Christmas won&#039;t be the last. They were right. Apache has issued another security update for the logging library that administrators must now install in their applications. As of Tuesday the latest version of Log4j that should be in systems running Java 8 is 2.17.1. […]" />
		<meta name="twitter:creator" content="@intent" />
		<meta name="twitter:image" content="https://i.itworldcanada.com/wp-content/uploads/2014/11/INSIDE-SLIDE-hands-coding.jpg" />
		<meta name="twitter:label1" content="Written by" />
		<meta name="twitter:data1" content="Howard Solomon" />
		<meta name="twitter:label2" content="Est. reading time" />
		<meta name="twitter:data2" content="2 minutes" />
		<meta name="google" content="nositelinkssearchbox" />
		<script type="application/ld+json" class="aioseo-schema">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</script>
		<!-- All in One SEO -->


<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];

	var gtm4wp_scrollerscript_debugmode         = false;
	var gtm4wp_scrollerscript_callbacktime      = 100;
	var gtm4wp_scrollerscript_readerlocation    = 350;
	var gtm4wp_scrollerscript_contentelementid  = "content";
	var gtm4wp_scrollerscript_scannertime       = 60;
//]]>
</script>
<!-- End Google Tag Manager for WordPress by gtm4wp.com --><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="IT World Canada &raquo; Feed" href="https://www.itworldcanada.com/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.itworldcanada.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.itworldcanada.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.itworldcanada.com/wp-includes/css/dashicons.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-ulike-css'  href='https://www.itworldcanada.com/wp-content/plugins/wp-ulike/assets/css/wp-ulike.min.css?ver=4.5.8' type='text/css' media='all' />
<link rel='stylesheet' id='wp-ulike-pro-css'  href='https://www.itworldcanada.com/wp-content/plugins/wp-ulike-pro/public/assets/css/wp-ulike-pro.min.css?ver=1.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://www.itworldcanada.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=810534ce963cec6bd2e7978db2c935c9x' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Poppins%3A400%2C300%2C600%7CSource+Sans+Pro%3A400%2C300%2C600%7COpen+Sans%3A400%2C600%2C700%2C300%7CRoboto%3A400%2C500%2C700%2C300%2C600%7CRoboto%3A900%7CMontserrat%3A400%7CPoppins%3A300%2C600%2C400%7CSource+Sans+Pro%3A400&#038;display=swap&#038;ver=11.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='algolia-autocomplete-css'  href='https://www.itworldcanada.com/wp-content/plugins/wp-search-with-algolia/css/algolia-autocomplete.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://www.itworldcanada.com/wp-content/themes/Newspaper/style.css?ver=11.3.2' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-theme-child-css'  href='https://www.itworldcanada.com/wp-content/themes/Newspaper-child/style.css?ver=11.3.2c' type='text/css' media='all' />
<link rel='stylesheet' id='font_awesome-css'  href='https://www.itworldcanada.com/wp-content/plugins/td-composer/assets/fonts/font-awesome/font-awesome.css?ver=810534ce963cec6bd2e7978db2c935c9x' type='text/css' media='all' />
<link rel='stylesheet' id='td-legacy-framework-front-style-css'  href='https://www.itworldcanada.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=810534ce963cec6bd2e7978db2c935c9x' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css'  href='https://www.itworldcanada.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=79f8a1d02f05c15c98a62e68cd419e0b' type='text/css' media='all' />
<script type='text/javascript' src='https://www.itworldcanada.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.itworldcanada.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.itworldcanada.com/wp-content/plugins/duracelltomi-google-tag-manager/js/analytics-talk-content-tracking.js?ver=1.14.1' id='gtm4wp-scroll-tracking-js'></script>
<link rel="https://api.w.org/" href="https://www.itworldcanada.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.itworldcanada.com/wp-json/wp/v2/posts/469537" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.itworldcanada.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.itworldcanada.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://www.itworldcanada.com/?p=469537' />
<link rel="alternate" type="application/json+oembed" href="https://www.itworldcanada.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.itworldcanada.com%2Farticle%2Fapache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j%2F469537" />
<link rel="alternate" type="text/xml+oembed" href="https://www.itworldcanada.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.itworldcanada.com%2Farticle%2Fapache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j%2F469537&#038;format=xml" />
<script type="text/javascript">//<![CDATA[
  function external_links_in_new_windows_loop() {
    if (!document.links) {
      document.links = document.getElementsByTagName('a');
    }
    var change_link = false;
    var force = '';
    var ignore = '';

    for (var t=0; t<document.links.length; t++) {
      var all_links = document.links[t];
      change_link = false;
      
      if(document.links[t].hasAttribute('onClick') == false) {
        // forced if the address starts with http (or also https), but does not link to the current domain
        if(all_links.href.search(/^http/) != -1 && all_links.href.search('www.itworldcanada.com') == -1 && all_links.href.search(/^#/) == -1) {
          // console.log('Changed ' + all_links.href);
          change_link = true;
        }
          
        if(force != '' && all_links.href.search(force) != -1) {
          // forced
          // console.log('force ' + all_links.href);
          change_link = true;
        }
        
        if(ignore != '' && all_links.href.search(ignore) != -1) {
          // console.log('ignore ' + all_links.href);
          // ignored
          change_link = false;
        }

        if(change_link == true) {
          // console.log('Changed ' + all_links.href);
          document.links[t].setAttribute('onClick', 'javascript:window.open(\''+all_links.href+'\'); return false;');
          document.links[t].removeAttribute('target');
        }
      }
    }
  }
  
  // Load
  function external_links_in_new_windows_load(func)
  {  
    var oldonload = window.onload;
    if (typeof window.onload != 'function'){
      window.onload = func;
    } else {
      window.onload = function(){
        oldonload();
        func();
      }
    }
  }

  external_links_in_new_windows_load(external_links_in_new_windows_loop);
  //]]></script>


<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pagePostType":"post","pagePostType2":"single-post","pageCategory":["privacy-and-security"],"pageAttributes":["apache","di","patches","postmedia","security-strategies","top-story"],"pagePostAuthor":"Howard Solomon","pagePostDate":"December 29, 2021","pagePostDateYear":"2021","pagePostDateMonth":"12","pagePostDateDay":"29","pagePostTerms":{"category":["Privacy &amp; Security"],"post_tag":["Apache","DI","patches","postmedia","security strategies","Top Story"],"frames":["Risk"],"subframes":["Tell Me Something I Don’t Know"]}};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5NVWMFZ');//]]>
</script>
<!-- End Google Tag Manager -->
<!-- End Google Tag Manager for WordPress by gtm4wp.com -->
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<!--
<script type='text/javascript'>
(function() {
var useSSL = 'https:' == document.location.protocol;
var src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
</script>
-->

<script type='text/javascript'>
	window.googletag = window.googletag || {cmd: []};
	var slot_time = 300000;
	  var slot_leaderboardros;
	var slot_mobileleaderboardros;
	var slot_skyscraperros;
	var slot_supersky;
	var slot_bigboxros;
	var slot_bigbox2ros;
	var slot_footer;
googletag.cmd.push(function() {
			
slot_leaderboardros = googletag.defineSlot("/3034/idg.ca.itwcepp", [[728, 90],[970, 250],[900, 150]], "div-gpt-leaderboardros").addService(googletag.pubads()).setTargeting("pos","leaderboardros");
slot_mobileleaderboardros = googletag.defineSlot("/3034/idg.ca.itwcepp", [[300, 100],[300, 50],[320, 50]], "div-gpt-mobileleaderboardros").addService(googletag.pubads()).setTargeting("pos","mobileleaderboardros");
slot_skyscraperros = googletag.defineSlot("/3034/idg.ca.itwcepp", [[160, 600],[300, 600]], "div-gpt-skyscraperros").addService(googletag.pubads()).setTargeting("pos","skyscraperros");
slot_supersky = googletag.defineSlot("/3034/idg.ca.itwcepp", [300, 600], "div-gpt-supersky").addService(googletag.pubads()).setTargeting("pos","supersky");
slot_bigboxros = googletag.defineSlot("/3034/idg.ca.itwcepp", [300, 250], "div-gpt-bigboxros").addService(googletag.pubads()).setTargeting("pos","bigboxros");
slot_bigbox2ros = googletag.defineSlot("/3034/idg.ca.itwcepp", [300, 250], "div-gpt-bigbox2ros").addService(googletag.pubads()).setTargeting("pos","bigbox2ros");
slot_skybox = googletag.defineSlot("/3034/idg.ca.itwcepp", [[300, 250],[300, 600]], "div-gpt-skybox").addService(googletag.pubads()).setTargeting("pos","skybox");
slot_footer = googletag.defineSlot('/3034/idg.ca.itwcepp', [[900, 300],[970, 250],[900, 150],[300, 100],[300, 50],[320, 50]], 'div-gpt-footer').addService(googletag.pubads()).setTargeting("pos","footer");
googletag.defineOutOfPageSlot('/3034/idg.ca.itwcepp', 'div-gpt-inter').addService(googletag.pubads()).setTargeting("pos","inter");	
	
googletag.pubads().setTargeting("wpid",["469537"]);googletag.pubads().setTargeting("ptype",["article"]);googletag.pubads().setTargeting("c",["privacy-and-security",]);googletag.pubads().setTargeting("t",["apache","di","patches","postmedia","security-strategies","top-story",]);googletag.pubads().enableSingleRequest();
googletag.enableServices();
});

</script>


<!-- Facebook Pixel Code -->
<meta name="facebook-domain-verification" content="thjgglw3183g3lk6sx7ccfhyfu2dp9" />


<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
 fbq('init', '1348048558951275'); 
fbq('track', 'PageView');
</script>
<noscript>
 <img height="1" width="1" 
src="https://www.facebook.com/tr?id=1348048558951275&ev=PageView
&noscript=1"/>
</noscript>
<!-- End Facebook Pixel Code -->



    <!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script>
        window.tdb_globals = {"wpRestNonce":"9ec39785a1","wpRestUrl":"https:\/\/www.itworldcanada.com\/wp-json\/","permalinkStructure":"\/%postname%\/%post_id%","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"on","origPostEditUrl":null};
    </script>
    			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.itworldcanada.com\/wp-admin\/","wpRestNonce":"9ec39785a1","wpRestUrl":"https:\/\/www.itworldcanada.com\/wp-json\/","permalinkStructure":"\/%postname%\/%post_id%"};
			</script>
			    <script>
        window.tdaGlobal = {"adminUrl":"https:\/\/www.itworldcanada.com\/wp-admin\/","wpRestNonce":"9ec39785a1","wpRestUrl":"https:\/\/www.itworldcanada.com\/wp-json\/","permalinkStructure":"\/%postname%\/%post_id%","postId":454486};
    </script>
    		<style>
			.algolia-search-highlight {
				background-color: #fffbcc;
				border-radius: 2px;
				font-style: normal;
			}
		</style>
		<link rel="amphtml" href="https://www.itworldcanada.com/article/apache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j/469537?amp=1">
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<style type="text/css">.ulp-form{max-width:480px!important;}</style><link rel="icon" href="https://i.itworldcanada.com/wp-content/uploads/2018/06/cropped-amp-icon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://i.itworldcanada.com/wp-content/uploads/2018/06/cropped-amp-icon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i.itworldcanada.com/wp-content/uploads/2018/06/cropped-amp-icon-180x180.png" />
<meta name="msapplication-TileImage" content="https://i.itworldcanada.com/wp-content/uploads/2018/06/cropped-amp-icon-270x270.png" />

<!-- Button style compiled by theme -->

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                body .tdm-social-item i {
                    color: #d2202f;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #d2202f;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #d2202f;
                }
                .tdm-btn-style1 {
					background-color: #d2202f;
				}
				.tdm-btn-style2:before {
				    border-color: #d2202f;
				}
				.tdm-btn-style2 {
				    color: #d2202f;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #d2202f;
                    -moz-box-shadow: 0 2px 16px #d2202f;
                    box-shadow: 0 2px 16px #d2202f;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #d2202f;
                    -moz-box-shadow: 0 4px 26px #d2202f;
                    box-shadow: 0 4px 26px #d2202f;
				}
</style>

	<style id="tdw-css-placeholder"></style></head>

<body class="post-template-default single single-post postid-469537 single-format-standard td-standard-pack apache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j global-block-template-9 tdb_template_454486 tdb-template  tdc-header-template  tdc-footer-template td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

            <div class="td-scroll-up  td-hide-scroll-up-on-mob" style="display:none;"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/ITWorldCa" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.linkedin.com/company/itworldcanada/" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/intent/user?screen_name=itworldca" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCvlbuIiCz691utVrZYbYhIA" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-placeholder-container"><ul id="menu-placeholder" class="td-mobile-main-menu"><li id="menu-item-60360" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-60360"><a href="https://www.itworldcanada.com/category/leadership">Leadership</a></li>
<li id="menu-item-60361" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-60361"><a href="https://www.itworldcanada.com/category/privacy-and-security">Privacy &amp; Security</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://www.itworldcanada.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
                    <div class="td-header-template-wrap" style="position: relative">
                                    <div class="td-header-mobile-wrap ">
                        <div id="tdi_1" class="tdc-zone"><div class="tdc_zone tdi_2  wpb_row td-pb-row tdc-element-style"  >
<style scoped>

/* custom css */
.tdi_2{
                    min-height: 0;
                }.td-header-mobile-wrap{
                    position: relative;
                    width: 100%;
                }
/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_2{
position:relative;
}
}

</style>
<div class="tdi_1_rand_style td-element-style" ><style>
/* phone */
@media (max-width: 767px)
{
.tdi_1_rand_style{
background-color:#222222 !important;
}
}
 </style></div><div id="tdi_3" class="tdc-row"><div class="vc_row tdi_4  wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_4,
                .tdi_4 .tdc-columns{
                    min-height: 0;
                }.tdi_4,
				.tdi_4 .tdc-columns{
				    display: block;
				}.tdi_4 .tdc-columns{
				    width: 100%;
				}

/* phone */
@media (max-width: 767px){
@media (min-width: 768px) {
	                .tdi_4 {
	                    margin-left: -0px;
	                    margin-right: -0px;
	                }
	                .tdi_4 .tdc-row-video-background-error,
	                .tdi_4 .vc_column {
	                    padding-left: 0px;
	                    padding-right: 0px;
	                }
                }
}
</style><div class="vc_column tdi_6  wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped>

/* custom css */
.tdi_6{
                    vertical-align: baseline;
                }.tdi_6 > .wpb_wrapper,
				.tdi_6 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_6 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_6 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_6 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}

/* phone */
@media (max-width: 767px){
.tdi_6{
                    vertical-align: middle;
                }
}
/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_6{
width:20% !important;
display:inline-block !important;
}
}

</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_mobile_menu tdi_7 td-pb-border-top td_block_template_9 tdb-header-align"  data-td-block-uid="tdi_7" >
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_7{
margin-left:-13px !important;
}
}

</style>
<style>
/* custom css */
.tdb-header-align{
                  vertical-align: middle;
                }.tdb_mobile_menu{
                  margin-bottom: 0;
                  clear: none;
                }.tdb_mobile_menu a{
                  display: inline-block !important;
                  position: relative;
                  text-align: center;
                  color: #4db2ec;
                }.tdb_mobile_menu a > span{
                  display: flex;
                  align-items: center;
                  justify-content: center;
                }.tdb_mobile_menu svg{
                  height: auto;
                }.tdb_mobile_menu svg,
                .tdb_mobile_menu svg *{
                  fill: #4db2ec;
                }#tdc-live-iframe .tdb_mobile_menu a{
                  pointer-events: none;
                }.tdi_7{
                    display: inline-block;
                }.tdi_7 .tdb-mobile-menu-button i{
                    font-size: 22px;
                
                    width: 55px;
					height: 55px;
					line-height:  55px;
                }.tdi_7 .tdb-mobile-menu-button svg{
                    width: 22px;
                }.tdi_7 .tdb-mobile-menu-button .tdb-mobile-menu-icon-svg{
                    width: 55px;
					height: 55px;
                }.tdi_7 .tdb-mobile-menu-button{
                    color: #ffffff;
                }.tdi_7 .tdb-mobile-menu-button svg,
                .tdi_7 .tdb-mobile-menu-button svg *{
                    fill: #ffffff;
                }

/* phone */
@media (max-width: 767px){
.tdi_7 .tdb-mobile-menu-button i{
                    font-size: 27px;
                
                    width: 54px;
					height: 54px;
					line-height:  54px;
                }.tdi_7 .tdb-mobile-menu-button svg{
                    width: 27px;
                }.tdi_7 .tdb-mobile-menu-button .tdb-mobile-menu-icon-svg{
                    width: 54px;
					height: 54px;
                }
}
</style><div class="tdb-block-inner td-fix-index"><a class="tdb-mobile-menu-button" aria-label="menu-button" href="#"><i class="tdb-mobile-menu-icon td-icon-mobile"></i></a></div></div> <!-- ./block --></div></div><div class="vc_column tdi_9  wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped>

/* custom css */
.tdi_9{
                    vertical-align: baseline;
                }.tdi_9 > .wpb_wrapper,
				.tdi_9 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_9 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_9 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_9 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}

/* phone */
@media (max-width: 767px){
.tdi_9{
                    vertical-align: middle;
                }
}
/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_9{
width:60% !important;
display:inline-block !important;
}
}

</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_logo tdi_10 td-pb-border-top td_block_template_9 tdb-header-align"  data-td-block-uid="tdi_10" >
<style>
/* custom css */
.tdb_header_logo{
                  margin-bottom: 0;
                  clear: none;
                }.tdb_header_logo .tdb-logo-a,
                .tdb_header_logo h1{
                  display: flex;
                  pointer-events: auto;
                  align-items: flex-start;
                }.tdb_header_logo h1{
                  margin: 0;
                  line-height: 0;
                }.tdb_header_logo .tdb-logo-img-wrap img{
                  display: block;
                }.tdb_header_logo .tdb-logo-svg-wrap + .tdb-logo-img-wrap{
                  display: none;
                }.tdb_header_logo .tdb-logo-svg-wrap svg{
                  width: 50px;
                  display: block;
                }.tdb_header_logo .tdb-logo-text-wrap{
                  display: flex;
                }.tdb_header_logo .tdb-logo-text-title,
                .tdb_header_logo .tdb-logo-text-tagline{
                  -webkit-transition: all 0.2s ease;
                  transition: all 0.2s ease;
                }.tdb_header_logo .tdb-logo-text-title{
                  background-size: cover;
                  background-position: center center;
                  font-size: 75px;
                  font-family: serif;
                  line-height: 1.1;
                  color: #222;
                  white-space: nowrap;
                }.tdb_header_logo .tdb-logo-text-tagline{
                  margin-top: 2px;
                  font-size: 12px;
                  font-family: serif;
                  letter-spacing: 1.8px;
                  line-height: 1;
                  color: #767676;
                }.tdb_header_logo .tdb-logo-icon{
                  position: relative;
                  font-size: 46px;
                  color: #000;
                }.tdb_header_logo .tdb-logo-icon-svg{
                  line-height: 0;
                }.tdb_header_logo .tdb-logo-icon-svg svg{
                  width: 46px;
                  height: auto;
                }.tdb_header_logo .tdb-logo-icon-svg svg,
                .tdb_header_logo .tdb-logo-icon-svg svg *{
                  fill: #000;
                }.tdi_10 .tdb-logo-a,
                .tdi_10 h1{
                    flex-direction: row;
                
                    align-items: center;
                
                    justify-content: center;
                }.tdi_10 .tdb-logo-svg-wrap{
                    display: block;
                }.tdi_10 .tdb-logo-img-wrap{
                    display: none;
                }.tdi_10 .tdb-logo-text-tagline{
                    margin-top: -3px;
                    margin-left: 0;
                
                    display: block;
                
                    font-family:Montserrat !important;;
                }.tdi_10 .tdb-logo-text-wrap{
                    flex-direction: column;
                
                    align-items: center;
                }.tdi_10 .tdb-logo-icon{
                    top: 0px;
                
                    display: block;
                }.tdi_10 .tdb-logo-text-title{
                    color: #ffffff;
                }@media (max-width: 767px) {
                  .tdb_header_logo .tdb-logo-text-title {
                    font-size: 36px;
                  }
                }@media (max-width: 767px) {
                  .tdb_header_logo .tdb-logo-text-tagline {
                    font-size: 11px;
                  }
                }

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_10 .tdb-logo-img{
                    max-width: 186px;
                }.tdi_10 .tdb-logo-text-tagline{
                    margin-top: -2px;
                    margin-left: 0;
                }
}

/* phone */
@media (max-width: 767px){
.tdi_10 .tdb-logo-svg-wrap + .tdb-logo-img-wrap{
                    display: none;
                }.tdi_10 .tdb-logo-img-wrap{
                    display: block;
                }.tdi_10 .tdb-logo-text-title{
                    display: none;
                
                    font-family:Roboto !important;font-size:20px !important;font-weight:900 !important;text-transform:uppercase !important;letter-spacing:1px !important;;
                }
}
</style><div class="tdb-block-inner td-fix-index"><a class="tdb-logo-a" href="https://www.itworldcanada.com/"><span class="tdb-logo-img-wrap"><img class="tdb-logo-img" src="https://i.itworldcanada.com/wp-content/uploads/2021/03/it-world-canada.png" alt="IT World Canada"  title="IT World Canada - IT News"  width="300" height="33" /></span><span class="tdb-logo-text-wrap"><span class="tdb-logo-text-title">NewsPaper</span></span></a></div></div> <!-- ./block --></div></div><div class="vc_column tdi_12  wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped>

/* custom css */
.tdi_12{
                    vertical-align: baseline;
                }.tdi_12 > .wpb_wrapper,
				.tdi_12 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_12 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_12 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_12 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}

/* phone */
@media (max-width: 767px){
.tdi_12{
                    vertical-align: middle;
                }
}
/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_12{
width:20% !important;
display:inline-block !important;
}
}

</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_mobile_search tdi_13 td-pb-border-top td_block_template_9 tdb-header-align"  data-td-block-uid="tdi_13" >
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_13{
margin-right:-19px !important;
margin-bottom:0px !important;
}
}

</style>
<style>
/* custom css */
.tdb_mobile_search{
                  margin-bottom: 0;
                  clear: none;
                }.tdb_mobile_search a{
                  display: inline-block !important;
                  position: relative;
                  text-align: center;
                  color: #4db2ec;
                }.tdb_mobile_search a > span{
                  display: flex;
                  align-items: center;
                  justify-content: center;
                }.tdb_mobile_search svg{
                  height: auto;
                }.tdb_mobile_search svg,
                .tdb_mobile_search svg *{
                  fill: #4db2ec;
                }#tdc-live-iframe .tdb_mobile_search a{
                  pointer-events: none;
                }.tdi_13{
                    display: inline-block;
                
                    float: right;
                    clear: none;
                }.tdi_13 .tdb-header-search-button-mob i{
                    font-size: 22px;
                
                    width: 55px;
					height: 55px;
					line-height:  55px;
                }.tdi_13 .tdb-header-search-button-mob svg{
                    width: 22px;
                }.tdi_13 .tdb-header-search-button-mob .tdb-mobile-search-icon-svg{
                    width: 55px;
					height: 55px;
					display: flex;
                    justify-content: center;
                }.tdi_13 .tdb-header-search-button-mob{
                    color: #ffffff;
                }.tdi_13 .tdb-header-search-button-mob svg,
                .tdi_13 .tdb-header-search-button-mob svg *{
                    fill: #ffffff;
                }
</style><div class="tdb-block-inner td-fix-index"><a class="tdb-header-search-button-mob dropdown-toggle" href="#" role="button" aria-label="Search" data-toggle="dropdown"><i class="tdb-mobile-search-icon td-icon-search"></i></a></div></div> <!-- ./block --></div></div></div></div><div id="tdi_14" class="tdc-row stretch_row"><div class="vc_row tdi_15  wpb_row td-pb-row tdc-element-style" >
<style scoped>

/* custom css */
.tdi_15,
                .tdi_15 .tdc-columns{
                    min-height: 0;
                }.tdi_15,
				.tdi_15 .tdc-columns{
				    display: block;
				}.tdi_15 .tdc-columns{
				    width: 100%;
				}
/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_15{
margin-bottom:0px !important;
padding-top:10px !important;
padding-bottom:0px !important;
position:relative;
}
}

</style>
<div class="tdi_14_rand_style td-element-style" ><style>
/* phone */
@media (max-width: 767px)
{
.tdi_14_rand_style{
background-color:#ffffff !important;
}
}
 </style></div><div class="vc_column tdi_17  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_17{
                    vertical-align: baseline;
                }.tdi_17 > .wpb_wrapper,
				.tdi_17 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_17 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_17 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_17 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="td-a-rec td-a-rec-id-custom_ad_2  td-rec-hide-on-m td-rec-hide-on-tl td-rec-hide-on-tp tdi_18 td_block_template_9">
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_18{
margin-bottom:10px !important;
padding-bottom:0px !important;
}
}

</style>
<style>
/* custom css */
.tdi_18.td-a-rec{
					text-align: center;
				}.tdi_18 .td-element-style{
					z-index: -1;
				}
</style><div id=div-gpt-mobileleaderboardros> <script>googletag.cmd.push(function() {googletag.display('div-gpt-mobileleaderboardros');
setInterval(function(){googletag.pubads().refresh([slot_mobileleaderboardros]);}, slot_time);
});</script> 
</div></div></div></div></div></div></div></div>                    </div>
                                    <div class="td-header-mobile-sticky-wrap tdc-zone-sticky-invisible tdc-zone-sticky-inactive" style="display: none">
                        <div id="tdi_19" class="tdc-zone"><div class="tdc_zone tdi_20  wpb_row td-pb-row" data-sticky-offset="0" >
<style scoped>

/* custom css */
.tdi_20{
                    min-height: 0;
                }.td-header-mobile-sticky-wrap.td-header-active{
                    opacity: 1;
                }
</style><div id="tdi_21" class="tdc-row"><div class="vc_row tdi_22  wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_22,
                .tdi_22 .tdc-columns{
                    min-height: 0;
                }.tdi_22,
				.tdi_22 .tdc-columns{
				    display: block;
				}.tdi_22 .tdc-columns{
				    width: 100%;
				}
</style><div class="vc_column tdi_24  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_24{
                    vertical-align: baseline;
                }.tdi_24 > .wpb_wrapper,
				.tdi_24 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_24 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_24 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_24 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"></div></div></div></div></div></div>                    </div>
                
                    <div class="td-header-desktop-wrap ">
                        <div id="tdi_25" class="tdc-zone"><div class="tdc_zone tdi_26  wpb_row td-pb-row tdc-element-style"  >
<style scoped>

/* custom css */
.tdi_26{
                    min-height: 0;
                }.td-header-desktop-wrap{
                    position: relative;
                }
/* inline tdc_css att */

.tdi_26{
position:relative;
}

</style>
<div class="tdi_25_rand_style td-element-style" ><style>
.tdi_25_rand_style{
background-color:#ffffff !important;
}
 </style></div><div id="tdi_27" class="tdc-row stretch_row"><div class="vc_row tdi_28  wpb_row td-pb-row tdc-row-content-vert-center" >
<style scoped>

/* custom css */
.tdi_28,
                .tdi_28 .tdc-columns{
                    min-height: 0;
                }.tdi_28,
				.tdi_28 .tdc-columns{
				    display: block;
				}.tdi_28 .tdc-columns{
				    width: 100%;
				}@media (min-width: 768px) {
	                .tdi_28 {
	                    margin-left: -0px;
	                    margin-right: -0px;
	                }
	                .tdi_28 .tdc-row-video-background-error,
	                .tdi_28 .vc_column {
	                    padding-left: 0px;
	                    padding-right: 0px;
	                }
                }@media (min-width: 767px) {
                    .tdi_28.tdc-row-content-vert-center,
                    .tdi_28.tdc-row-content-vert-center .tdc-columns {
                        display: flex;
                        align-items: center;
                        flex: 1;
                    }
                    .tdi_28.tdc-row-content-vert-bottom,
                    .tdi_28.tdc-row-content-vert-bottom .tdc-columns {
                        display: flex;
                        align-items: flex-end;
                        flex: 1;
                    }
                    .tdi_28.tdc-row-content-vert-center .td_block_wrap {
                        vertical-align: middle;
                    }
                    .tdi_28.tdc-row-content-vert-bottom .td_block_wrap {
                        vertical-align: bottom;
                    }
                }
/* inline tdc_css att */

.tdi_28{
padding-top:2px !important;
padding-right:10px !important;
padding-bottom:2px !important;
padding-left:10px !important;
}

.tdi_28 .td_block_wrap{ text-align:left }

</style><div class="vc_column tdi_30  wpb_column vc_column_container tdc-column td-pb-span9">
<style scoped>

/* custom css */
.tdi_30{
                    vertical-align: baseline;
                }.tdi_30 > .wpb_wrapper,
				.tdi_30 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_30 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_30 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_30 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
/* inline tdc_css att */

.tdi_30{
width:80% !important;
}

</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_date tdi_31 td-pb-border-top td_block_template_9 tdb-header-align"  data-td-block-uid="tdi_31" >
<style>

/* inline tdc_css att */

.tdi_31{
margin-top:-1px !important;
margin-right:32px !important;
}

</style>
<style>
/* custom css */
.tdb_header_date{
                  margin-bottom: 0;
                  clear: none;
                }.tdb_header_date .tdb-block-inner{
                  display: flex;
                  align-items: baseline;
                }.tdb_header_date .tdb-head-date-txt{
                  font-family: 'Open Sans', 'Open Sans Regular', sans-serif;
                  font-size: 11px;
                  line-height: 1;
                  color: #000;
                }.tdi_31{
                    display: inline-block;
                }
</style><div class="tdb-block-inner td-fix-index"><div class="tdb-head-date-txt">Wednesday, December 29, 2021</div></div></div> <!-- ./block --><div class="td_block_wrap tdb_mobile_horiz_menu tdi_32 td-pb-border-top td_block_template_9 tdb-header-align"  data-td-block-uid="tdi_32"  style=" z-index: 999;">
<style>

/* inline tdc_css att */

.tdi_32{
margin-top:-2px !important;
margin-bottom:0px !important;
}

</style>
<style>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</style><div id=tdi_32 class="td_block_inner td-fix-index"><div class="menu-hot-topics-container"><ul id="menu-hot-topics" class="tdb-horiz-menu"><li id="menu-item-435200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-435200"><a href="https://www.itworldcanada.com/maplesec"><div class="tdb-menu-item-text">MapleSEC</div></a></li>
<li id="menu-item-468043" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-468043"><a href="https://technicity.ca/"><div class="tdb-menu-item-text">Technicity GTA</div></a></li>
<li id="menu-item-457365" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-457365"><a href="https://www.itworldcanada.com/analytics-unleashed-sept-23-2021"><div class="tdb-menu-item-text">Analytics Unleashed</div></a></li>
<li id="menu-item-435198" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-435198"><a href="https://www.itworldcanada.com/category/work-from-home"><div class="tdb-menu-item-text">Work from home</div></a></li>
<li id="menu-item-435202" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-435202"><a href="https://www.itworldcanada.com/tag/itwc-morning-briefing"><div class="tdb-menu-item-text">Morning Briefing</div></a></li>
<li id="menu-item-443372" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-443372"><a href="https://www.itworldcanada.com/category/leadership"><div class="tdb-menu-item-text">Leadership</div></a></li>
</ul></div></div></div></div></div><div class="vc_column tdi_34  wpb_column vc_column_container tdc-column td-pb-span3">
<style scoped>

/* custom css */
.tdi_34{
                    vertical-align: baseline;
                }.tdi_34 > .wpb_wrapper,
				.tdi_34 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_34 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_34 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_34 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="tdm_block td_block_wrap tdm_block_socials tdi_35 tdm-content-horiz-left td-pb-border-top td_block_template_9"  data-td-block-uid="tdi_35" >
<style>

/* inline tdc_css att */

.tdi_35{
margin-top:-5px !important;
margin-bottom:-5px !important;
}

</style>
<style>
/* custom css */
.tdm_block.tdm_block_socials{
                  margin-bottom: 0;
                }.tdm-social-wrapper{
                  *zoom: 1;
                }.tdm-social-wrapper:before,
                .tdm-social-wrapper:after{
                  display: table;
                  content: '';
                  line-height: 0;
                }.tdm-social-wrapper:after{
                  clear: both;
                }.tdm-social-item-wrap{
                  display: inline-block;
                }.tdm-social-item{
                  position: relative;
                  display: inline-block;
                  vertical-align: middle;
                  -webkit-transition: all 0.2s;
                  transition: all 0.2s;
                  text-align: center;
                  -webkit-transform: translateZ(0);
                  transform: translateZ(0);
                }.tdm-social-item i{
                  font-size: 14px;
                  color: #4db2ec;
                  -webkit-transition: all 0.2s;
                  transition: all 0.2s;
                }.tdm-social-text{
                  display: none;
                  margin-top: -1px;
                  vertical-align: middle;
                  font-size: 13px;
                  color: #4db2ec;
                  -webkit-transition: all 0.2s;
                  transition: all 0.2s;
                }.tdm-social-item-wrap:hover i,
                .tdm-social-item-wrap:hover .tdm-social-text{
                  color: #000;
                }.tdm-social-item-wrap:last-child .tdm-social-text{
                  margin-right: 0 !important;
                }.tdi_35{
                    float: right;
                    clear: none;
                }
</style>
<style>
.tdi_36 .tdm-social-item i{
					font-size: 16px;
					vertical-align: middle;
				
					line-height: 30.4px;
				}.tdi_36 .tdm-social-item i.td-icon-twitter,
				.tdi_36 .tdm-social-item i.td-icon-linkedin,
				.tdi_36 .tdm-social-item i.td-icon-pinterest,
				.tdi_36 .tdm-social-item i.td-icon-blogger,
				.tdi_36 .tdm-social-item i.td-icon-vimeo{
					font-size: 12.8px;
				}.tdi_36 .tdm-social-item{
					width: 30.4px;
					height: 30.4px;
				
				    margin: 5px 10px 5px 0;
				}.tdi_36 .tdm-social-item-wrap:last-child .tdm-social-item{
				    margin-right: 0 !important;
				}.tdi_36 .tdm-social-item i,
				.tds-team-member2 .tdi_36.tds-social1 .tdm-social-item i{
					color: #000000;
				}.tdi_36 .tdm-social-item-wrap:hover i,
				.tds-team-member2 .tdi_36.tds-social1 .tdm-social-item:hover i{
					color: #d2202f;
				}.tdi_36 .tdm-social-text{
					margin-left: 2px;
				
					margin-right: 6px;
				
				    font-size:8px !important;
				}
</style><div class="tdm-social-wrapper tds-social1 tdi_36"><div class="tdm-social-item-wrap"><a href="https://www.facebook.com/ITWorldCa"  target="_blank"  title="Facebook" class="tdm-social-item"><i class="td-icon-font td-icon-facebook"></i></a><a href="https://www.facebook.com/ITWorldCa"  target="_blank" class="tdm-social-text" >Facebook</a></div><div class="tdm-social-item-wrap"><a href="https://www.linkedin.com/company/itworldcanada/"  target="_blank"  title="Linkedin" class="tdm-social-item"><i class="td-icon-font td-icon-linkedin"></i></a><a href="https://www.linkedin.com/company/itworldcanada/"  target="_blank" class="tdm-social-text" >Linkedin</a></div><div class="tdm-social-item-wrap"><a href="https://twitter.com/intent/user?screen_name=itworldca"  target="_blank"  title="Twitter" class="tdm-social-item"><i class="td-icon-font td-icon-twitter"></i></a><a href="https://twitter.com/intent/user?screen_name=itworldca"  target="_blank" class="tdm-social-text" >Twitter</a></div><div class="tdm-social-item-wrap"><a href="https://www.youtube.com/channel/UCvlbuIiCz691utVrZYbYhIA"  target="_blank"  title="Youtube" class="tdm-social-item"><i class="td-icon-font td-icon-youtube"></i></a><a href="https://www.youtube.com/channel/UCvlbuIiCz691utVrZYbYhIA"  target="_blank" class="tdm-social-text" >Youtube</a></div></div></div><div class="td_block_wrap tdb_search_form tdi_37 td-pb-border-top td_block_template_9"  data-td-block-uid="tdi_37" >
<style>

/* inline tdc_css att */

.tdi_37{
margin-top:0px !important;
margin-bottom:0px !important;
padding-top:0px !important;
padding-bottom:5px !important;
}

</style>
<style>
/* custom css */
.tdb_search_form{
                  margin-bottom: 40px;
                }.tdb_search_form .tdb-search-form-inner{
                  position: relative;
                  display: flex;
                  background-color: #fff;
                }.tdb_search_form .tdb-search-form-border{
                  position: absolute;
                  top: 0;
                  left: 0;
                  width: 100%;
                  height: 100%;
                  border: 1px solid #e1e1e1;
                  pointer-events: none;
                }.tdb_search_form .tdb-search-form-input:focus + .tdb-search-form-border{
                  border-color: #b0b0b0;
                }.tdb_search_form .tdb-search-form-input:not([value=""]) + .tdb-search-form-border + .tdb-search-form-placeholder{
                  display: none;
                }.tdb_search_form .tdb-search-form-input,
                .tdb_search_form .tdb-search-form-btn{
                  height: auto;
                  min-height: 32px;
                }.tdb_search_form .tdb-search-form-input{
                  position: relative;
                  flex: 1;
                  background-color: transparent;
                  line-height: 19px;
                  border: 0;
                }.tdb_search_form .tdb-search-form-placeholder{
                  position: absolute;
                  top: 50%;
                  transform: translateY(-50%);
                  padding: 3px 9px;
                  font-size: 12px;
                  line-height: 21px;
                  color: #999;
                  -webkit-transition: all 0.3s ease;
                  transition: all 0.3s ease;
                  pointer-events: none;
                }.tdb_search_form .tdb-search-form-input:focus + .tdb-search-form-border + .tdb-search-form-placeholder{
                  opacity: 0;
                }.tdb_search_form .tdb-search-form-btn{
                  text-shadow: none;
                  padding: 7px 15px 8px 15px;
                  line-height: 16px;
                  margin: 0;
                  background-color: #222222;
                  font-family: 'Roboto', sans-serif;
                  font-size: 13px;
                  font-weight: 500;
                  color: #fff;
                  z-index: 1;
                  -webkit-transition: all 0.3s ease;
                  transition: all 0.3s ease;
                }.tdb_search_form .tdb-search-form-btn:hover{
                  background-color: #4db2ec;
                }.tdb_search_form .tdb-search-form-btn i,
                .tdb_search_form .tdb-search-form-btn span{
                  display: inline-block;
                  vertical-align: middle;
                }.tdb_search_form .tdb-search-form-btn i{
                  position: relative;
                  font-size: 12px;
                }.tdb_search_form .tdb-search-form-btn .tdb-search-form-btn-icon{
                  position: relative;
                }.tdb_search_form .tdb-search-form-btn .tdb-search-form-btn-icon-svg{
                  line-height: 0;
                }.tdb_search_form .tdb-search-form-btn svg{
                  width: 12px;
                  height: auto;
                }.tdb_search_form .tdb-search-form-btn svg,
                .tdb_search_form .tdb-search-form-btn svg *{
                  fill: #fff;
                  -webkit-transition: all 0.3s ease;
                  transition: all 0.3s ease;
                }.tdb_search_form .tdb-search-msg{
                  font-size: 12px;
                }.td-theme-wrap .tdi_37{
					text-align: right;
				}.tdi_37 .tdb-search-form-input:focus + .tdb-search-form-border + .tdb-search-form-placeholder{
                    top: -0%;
                    transform: translateY(0);
                }.tdi_37 .tdb-search-form-btn-icon{
                    top: 0px;
                }.tdi_37 .tdb-search-msg{
					margin-top: 11px;
				}
</style><div class="tdb-block-inner td-fix-index"><form method="get" class="tdb-search-form" action="https://www.itworldcanada.com/"><div role="search" class="tdb-search-form-inner"><input id="tdb-search-form-input" class="tdb-search-form-input" type="text" value="" name="s" /><div class="tdb-search-form-border"></div><button class="wpb_button wpb_btn-inverse tdb-search-form-btn" aria-label="Search" type="submit"><i class="tdb-search-form-btn-icon tdc-font-fa tdc-font-fa-search"></i></div></form></div></div></div></div></div></div><div id="tdi_38" class="tdc-row stretch_row"><div class="vc_row tdi_39  wpb_row td-pb-row tdc-element-style" >
<style scoped>

/* custom css */
.tdi_39,
                .tdi_39 .tdc-columns{
                    min-height: 60px;
                }.tdi_39,
				.tdi_39 .tdc-columns{
				    display: block;
				}.tdi_39 .tdc-columns{
				    width: 100%;
				}@media (min-width: 768px) {
	                .tdi_39 {
	                    margin-left: -8px;
	                    margin-right: -8px;
	                }
	                .tdi_39 .tdc-row-video-background-error,
	                .tdi_39 .vc_column {
	                    padding-left: 8px;
	                    padding-right: 8px;
	                }
                }

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
@media (min-width: 768px) {
	                .tdi_39 {
	                    margin-left: -10px;
	                    margin-right: -10px;
	                }
	                .tdi_39 .tdc-row-video-background-error,
	                .tdi_39 .vc_column {
	                    padding-left: 10px;
	                    padding-right: 10px;
	                }
                }
}
/* inline tdc_css att */

.tdi_39{
margin-bottom:0px !important;
padding-bottom:0px !important;
position:relative;
}

.tdi_39 .td_block_wrap{ text-align:left }

</style>
<div class="tdi_38_rand_style td-element-style" ><style>
.tdi_38_rand_style{
background-color:#151515 !important;
}
 </style></div><div class="vc_column tdi_41  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_41{
                    vertical-align: baseline;
                }.tdi_41 > .wpb_wrapper,
				.tdi_41 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_41 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_41 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_41 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_logo tdi_42 td-pb-border-top td_block_template_9 tdb-header-align"  data-td-block-uid="tdi_42" >
<style>

/* inline tdc_css att */

.tdi_42{
margin-right:21px !important;
}

</style>
<style>
/* custom css */
.tdi_42{
                    display: inline-block;
                }.tdi_42 .tdb-logo-a,
                .tdi_42 h1{
                    flex-direction: row;
                
                    align-items: center;
                
                    justify-content: center;
                }.tdi_42 .tdb-logo-svg-wrap{
                    display: block;
                }.tdi_42 .tdb-logo-svg-wrap + .tdb-logo-img-wrap{
                    display: none;
                }.tdi_42 .tdb-logo-img{
                    max-width: 160px;
                }.tdi_42 .tdb-logo-text-tagline{
                    margin-top: -3px;
                    margin-left: 0;
                
                    font-family:Montserrat !important;;
                }.tdi_42 .tdb-logo-text-title{
                    display: none;
                
                    color: #ffffff;
                
                    font-family:Roboto !important;font-size:20px !important;font-weight:900 !important;text-transform:uppercase !important;letter-spacing:1px !important;;
                }.tdi_42 .tdb-logo-text-wrap{
                    flex-direction: column;
                
                    align-items: center;
                }.tdi_42 .tdb-logo-icon{
                    top: 0px;
                
                    display: block;
                }

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_42 .tdb-logo-img{
                    max-width: 100px;
                }.tdi_42 .tdb-logo-img-wrap{
                    display: block;
                }.tdi_42 .tdb-logo-text-tagline{
                    margin-top: -2px;
                    margin-left: 0;
                }
}

/* phone */
@media (max-width: 767px){
.tdi_42 .tdb-logo-text-tagline{
                    display: none;
                }
}
</style><div class="tdb-block-inner td-fix-index"><a class="tdb-logo-a" href="https://www.itworldcanada.com/"><span class="tdb-logo-img-wrap"><img class="tdb-logo-img td-retina-data" data-retina="https://i.itworldcanada.com/wp-content/uploads/2021/03/it-world-canada.png" src="https://i.itworldcanada.com/wp-content/uploads/2021/03/it-world-canada.png" alt="IT World Canada"  title="IT World Canada - IT News"  width="300" height="33" /></span><span class="tdb-logo-text-wrap"><span class="tdb-logo-text-title">IT World Canada</span></span></a></div></div> <!-- ./block --><div class="td_block_wrap tdb_header_menu tdi_43 tds_menu_active1 tds_menu_sub_active1 tdb-head-menu-inline tdb-menu-items-in-more tdb-mm-align-screen td-pb-border-top td_block_template_9 tdb-header-align"  data-td-block-uid="tdi_43"  style=" z-index: 999;">
<style>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</style>
<style>
.tdi_43 .tdb-menu > li > a:after,
				.tdi_43 .tdb-menu-items-dropdown .td-subcat-more:after{
					background-color: #dd3333;
				
					bottom: 0px;
				}
</style>
<style>
.tdi_43 .tdb-menu ul .tdb-normal-menu.current-menu-item > a,
				.tdi_43 .tdb-menu ul .tdb-normal-menu.current-menu-ancestor > a,
				.tdi_43 .tdb-menu ul .tdb-normal-menu.current-category-ancestor > a,
				.tdi_43 .tdb-menu ul .tdb-normal-menu.tdb-hover > a,
				.tdi_43 .tdb-menu ul .tdb-normal-menu:hover > a,
				.tdi_43 .td-pulldown-filter-list li:hover a{
					color: #dd3333;
				}.tdi_43 .tdb-menu ul .tdb-normal-menu.current-menu-item > a .tdb-sub-menu-icon-svg svg,
				.tdi_43 .tdb-menu ul .tdb-normal-menu.current-menu-item > a .tdb-sub-menu-icon-svg svg *,
				.tdi_43 .tdb-menu ul .tdb-normal-menu.current-menu-ancestor > a .tdb-sub-menu-icon-svg svg,
				.tdi_43 .tdb-menu ul .tdb-normal-menu.current-menu-ancestor > a .tdb-sub-menu-icon-svg svg *,
				.tdi_43 .tdb-menu ul .tdb-normal-menu.current-category-ancestor > a .tdb-sub-menu-icon-svg svg,
				.tdi_43 .tdb-menu ul .tdb-normal-menu.current-category-ancestor > a .tdb-sub-menu-icon-svg svg *,
				.tdi_43 .tdb-menu ul .tdb-normal-menu.tdb-hover > a .tdb-sub-menu-icon-svg svg,
				.tdi_43 .tdb-menu ul .tdb-normal-menu.tdb-hover > a .tdb-sub-menu-icon-svg svg *,
				.tdi_43 .tdb-menu ul .tdb-normal-menu:hover > a .tdb-sub-menu-icon-svg svg,
				.tdi_43 .tdb-menu ul .tdb-normal-menu:hover > a .tdb-sub-menu-icon-svg svg *,
				.tdi_43 .td-pulldown-filter-list li:hover a .tdb-sub-menu-icon-svg svg,
				.tdi_43 .td-pulldown-filter-list li:hover a .tdb-sub-menu-icon-svg svg *{
					fill: #dd3333;
				}
</style><div id=tdi_43 class="td_block_inner td-fix-index"><div class="tdb-menu-items-pulldown tdb-menu-items-pulldown-inactive"><ul id="menu-main-navigation" class="tdb-block-menu tdb-menu tdb-menu-items-visible"><li id="menu-item-80458" class="wide-drop menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-first tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-80458 tdb-menu-item-inactive"><a href="https://www.itworldcanada.com/news"><div class="tdb-menu-item-text">Tech News</div><i class="tdb-sub-menu-icon td-icon-read-down"></i></a>
<ul class="sub-menu">
	<li id="menu-item-435159" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435159"><a href="https://www.itworldcanada.com/category/big-data-analytics"><div class="tdb-menu-item-text">Analytics</div></a></li>
	<li id="menu-item-435158" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435158"><a href="https://www.itworldcanada.com/category/ai"><div class="tdb-menu-item-text">Artificial Intelligence</div></a></li>
	<li id="menu-item-435167" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children tdb-menu-item tdb-normal-menu menu-item-435167 tdb-menu-item-inactive"><a href="https://www.itworldcanada.com/category/it-workplace"><div class="tdb-menu-item-text">IT Workplace</div><i class="tdb-sub-menu-icon td-icon-right-arrow"></i></a>
	<ul class="sub-menu">
		<li id="menu-item-435160" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435160"><a href="https://www.itworldcanada.com/category/careers"><div class="tdb-menu-item-text">Careers</div></a></li>
		<li id="menu-item-435170" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435170"><a href="https://www.itworldcanada.com/category/marketing-2"><div class="tdb-menu-item-text">Marketing</div></a></li>
		<li id="menu-item-435178" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435178"><a href="https://www.itworldcanada.com/category/work-from-home"><div class="tdb-menu-item-text">Work from home</div></a></li>
	</ul>
</li>
	<li id="menu-item-435161" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435161"><a href="https://www.itworldcanada.com/category/cloud"><div class="tdb-menu-item-text">Cloud</div></a></li>
	<li id="menu-item-435162" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435162"><a href="https://www.itworldcanada.com/category/digital-transformation"><div class="tdb-menu-item-text">Digital Transformation</div></a></li>
	<li id="menu-item-435163" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435163"><a href="https://www.itworldcanada.com/category/ecommerce"><div class="tdb-menu-item-text">Ecommerce</div></a></li>
	<li id="menu-item-435164" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435164"><a href="https://www.itworldcanada.com/category/education"><div class="tdb-menu-item-text">Education</div></a></li>
	<li id="menu-item-435165" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435165"><a href="https://www.itworldcanada.com/category/emerging-tech"><div class="tdb-menu-item-text">Emerging Tech</div></a></li>
	<li id="menu-item-435166" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435166"><a href="https://www.itworldcanada.com/category/infrastructure"><div class="tdb-menu-item-text">Infrastructure</div></a></li>
	<li id="menu-item-435168" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435168"><a href="https://www.itworldcanada.com/category/leadership"><div class="tdb-menu-item-text">Leadership</div></a></li>
	<li id="menu-item-435169" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435169"><a href="https://www.itworldcanada.com/category/managed-services"><div class="tdb-menu-item-text">Managed Services &amp; Outsourcing</div></a></li>
	<li id="menu-item-435171" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435171"><a href="https://www.itworldcanada.com/category/mobility"><div class="tdb-menu-item-text">Mobility</div></a></li>
	<li id="menu-item-435172" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435172"><a href="https://www.itworldcanada.com/category/opinion"><div class="tdb-menu-item-text">Opinion</div></a></li>
	<li id="menu-item-435173" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent tdb-menu-item tdb-normal-menu menu-item-435173"><a href="https://www.itworldcanada.com/category/privacy-and-security"><div class="tdb-menu-item-text">Privacy &amp; Security</div></a></li>
	<li id="menu-item-435174" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435174"><a href="https://www.itworldcanada.com/category/public-sector"><div class="tdb-menu-item-text">Public Sector</div></a></li>
	<li id="menu-item-435175" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435175"><a href="https://www.itworldcanada.com/category/software"><div class="tdb-menu-item-text">Software</div></a></li>
	<li id="menu-item-435176" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435176"><a href="https://www.itworldcanada.com/category/wireless-and-iot"><div class="tdb-menu-item-text">Wireless &amp; IoT</div></a></li>
	<li id="menu-item-435177" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item tdb-normal-menu menu-item-435177"><a href="https://www.itworldcanada.com/category/women-in-technology"><div class="tdb-menu-item-text">Women in Technology</div></a></li>
</ul>
</li>
<li id="menu-item-80462" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-80462 tdb-menu-item-inactive"><a href="/assets"><div class="tdb-menu-item-text">Resources</div><i class="tdb-sub-menu-icon td-icon-read-down"></i></a>
<ul class="sub-menu">
	<li id="menu-item-435179" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-435179"><a href="/assets"><div class="tdb-menu-item-text">Reports and Whitepapers</div></a></li>
	<li id="menu-item-377361" class="menu-item menu-item-type-post_type menu-item-object-page tdb-menu-item tdb-normal-menu menu-item-377361"><a title="Canadian CIO" href="https://www.itworldcanada.com/cio"><div class="tdb-menu-item-text">News for CIOs</div></a></li>
	<li id="menu-item-424878" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-424878"><a href="https://www.itworldcanada.com/cio#census"><div class="tdb-menu-item-text">CIO Census</div></a></li>
	<li id="menu-item-376761" class="menu-item menu-item-type-post_type menu-item-object-page tdb-menu-item tdb-normal-menu menu-item-376761"><a title="Digital Security" href="https://www.itworldcanada.com/digital-security"><div class="tdb-menu-item-text">Digital Security Zone</div></a></li>
	<li id="menu-item-435180" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-435180"><a href="/reports#webinars"><div class="tdb-menu-item-text">Webinar Highlight Reports</div></a></li>
	<li id="menu-item-435181" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-435181"><a href="/reports#roundtables"><div class="tdb-menu-item-text">Roundtable Highlight Reports</div></a></li>
	<li id="menu-item-91155" class="menu-item menu-item-type-post_type menu-item-object-page tdb-menu-item tdb-normal-menu menu-item-91155"><a href="https://www.itworldcanada.com/salarycalculator"><div class="tdb-menu-item-text">2021 IT Salary Calculator</div></a></li>
	<li id="menu-item-401492" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-401492"><a title="Artificial Intelligence Directory" href="/ai/"><div class="tdb-menu-item-text">AI Directory</div></a></li>
	<li id="menu-item-435182" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-435182"><a href="/talks"><div class="tdb-menu-item-text">ITWC Talks</div></a></li>
	<li id="menu-item-435183" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-435183"><a href="/hubs/"><div class="tdb-menu-item-text">Featured Partner Content Hubs</div></a></li>
	<li id="menu-item-91153" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-91153"><a href="http://digital.itwc.ca"><div class="tdb-menu-item-text">Digital Magazines</div></a></li>
	<li id="menu-item-80459" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-80459"><a href="/blog"><div class="tdb-menu-item-text">Blogs</div></a></li>
</ul>
</li>
<li id="menu-item-80477" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-80477 tdb-menu-item-inactive"><a title="ITWC Events: Technology Workshops, Roundtables, Webinars and more." href="https://www.itworldcanada.com/events"><div class="tdb-menu-item-text">Events</div><i class="tdb-sub-menu-icon td-icon-read-down"></i></a>
<ul class="sub-menu">
	<li id="menu-item-435184" class="menu-item menu-item-type-post_type menu-item-object-page tdb-menu-item tdb-normal-menu menu-item-435184"><a href="https://www.itworldcanada.com/maplesec"><div class="tdb-menu-item-text">MapleSEC</div></a></li>
	<li id="menu-item-467053" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-467053"><a href="https://technicity.ca/"><div class="tdb-menu-item-text">Technicity GTA</div></a></li>
	<li id="menu-item-457363" class="menu-item menu-item-type-post_type menu-item-object-page tdb-menu-item tdb-normal-menu menu-item-457363"><a href="https://www.itworldcanada.com/analytics-unleashed-sept-23-2021"><div class="tdb-menu-item-text">Analytics Unleashed</div></a></li>
	<li id="menu-item-443204" class="menu-item menu-item-type-post_type menu-item-object-page tdb-menu-item tdb-normal-menu menu-item-443204"><a href="https://www.itworldcanada.com/canadas-top-women-in-fintech-blockchain"><div class="tdb-menu-item-text">Canada’s Top Women in Fintech/Blockchain</div></a></li>
	<li id="menu-item-440286" class="menu-item menu-item-type-post_type menu-item-object-page tdb-menu-item tdb-normal-menu menu-item-440286"><a href="https://www.itworldcanada.com/canadas-top-women-in-cyber-security"><div class="tdb-menu-item-text">CANADA’S TOP WOMEN IN CYBERSECURITY</div></a></li>
	<li id="menu-item-440287" class="menu-item menu-item-type-post_type menu-item-object-page tdb-menu-item tdb-normal-menu menu-item-440287"><a href="https://www.itworldcanada.com/cio-of-the-year"><div class="tdb-menu-item-text">CIO OF THE YEAR</div></a></li>
	<li id="menu-item-446390" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-446390"><a href="https://digitaltransformationawards.ca/"><div class="tdb-menu-item-text">Digital Transformation Conference and Awards</div></a></li>
	<li id="menu-item-435186" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-435186"><a href="https://www.itworldcanada.com/events#upcoming"><div class="tdb-menu-item-text">UPCOMING EVENTS</div></a></li>
	<li id="menu-item-435187" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-435187"><a href="/events#flagship"><div class="tdb-menu-item-text">FLAGSHIP EVENTS</div></a></li>
	<li id="menu-item-435188" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-435188"><a href="https://www.itworldcanada.com/events?es=VIRTUAL"><div class="tdb-menu-item-text">VIrtual Events</div></a></li>
	<li id="menu-item-435189" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-435189"><a href="https://www.itworldcanada.com/events?es=Webinar"><div class="tdb-menu-item-text">Webinars</div></a></li>
	<li id="menu-item-435190" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-435190"><a href="https://www.itworldcanada.com/events?es=Roundtable"><div class="tdb-menu-item-text">Roundtables</div></a></li>
	<li id="menu-item-435467" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-435467"><a href="/events"><div class="tdb-menu-item-text">All IT World Canada Events</div></a></li>
</ul>
</li>
<li id="menu-item-80461" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-80461 tdb-menu-item-inactive"><a href="/video"><div class="tdb-menu-item-text">Videos</div><i class="tdb-sub-menu-icon td-icon-read-down"></i></a>
<ul class="sub-menu">
	<li id="menu-item-446424" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-446424"><a href="https://www.itworldcanada.com/cio#P2P"><div class="tdb-menu-item-text">President to President</div></a></li>
	<li id="menu-item-435192" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-435192"><a href="/video"><div class="tdb-menu-item-text">All Tech Videos</div></a></li>
</ul>
</li>
<li id="menu-item-406104" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-406104 tdb-menu-item-inactive"><a href="https://www.itworldcanada.com/podcasts"><div class="tdb-menu-item-text">Podcasts</div><i class="tdb-sub-menu-icon td-icon-read-down"></i></a>
<ul class="sub-menu">
	<li id="menu-item-435193" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-435193"><a href="https://www.itworldcanada.com/podcasts#cyber-security-today"><div class="tdb-menu-item-text">Cyber Security Today</div></a></li>
	<li id="menu-item-435194" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-435194"><a href="https://www.itworldcanada.com/podcasts#hashtag-trending"><div class="tdb-menu-item-text">#Hashtag Trending</div></a></li>
	<li id="menu-item-442008" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-442008"><a href="https://www.itworldcanada.com/category/leadership#podcast"><div class="tdb-menu-item-text">Leadership in the Digital Enterprise</div></a></li>
	<li id="menu-item-446389" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-446389"><a href="https://www.itworldcanada.com/category/leadership#podcast-deep"><div class="tdb-menu-item-text">Deeper Dive</div></a></li>
	<li id="menu-item-435195" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-435195"><a href="https://www.itbusiness.ca/cmo-digital#cmo-talks-podcast"><div class="tdb-menu-item-text">CMO Talks</div></a></li>
	<li id="menu-item-435196" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-435196"><a href="/podcasts"><div class="tdb-menu-item-text">ITWC Podcast Network</div></a></li>
</ul>
</li>
<li id="menu-item-444437" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-444437 tdb-menu-item-inactive"><a href="https://www.itworldcanada.com/blogger-opportunities"><div class="tdb-menu-item-text">Engage</div><i class="tdb-sub-menu-icon td-icon-read-down"></i></a>
<ul class="sub-menu">
	<li id="menu-item-91152" class="menu-item menu-item-type-post_type menu-item-object-page tdb-menu-item tdb-normal-menu menu-item-91152"><a href="https://www.itworldcanada.com/blogger-opportunities"><div class="tdb-menu-item-text">Blogger Opportunities</div></a></li>
	<li id="menu-item-425457" class="menu-item menu-item-type-post_type menu-item-object-page tdb-menu-item tdb-normal-menu menu-item-425457"><a href="https://www.itworldcanada.com/2020-vision"><div class="tdb-menu-item-text">2020 Vision</div></a></li>
	<li id="menu-item-377478" class="menu-item menu-item-type-post_type menu-item-object-page tdb-menu-item tdb-normal-menu menu-item-377478"><a href="https://www.itworldcanada.com/gartner"><div class="tdb-menu-item-text">Gartner Corner</div></a></li>
	<li id="menu-item-91150" class="menu-item menu-item-type-post_type menu-item-object-page tdb-menu-item tdb-normal-menu menu-item-91150"><a href="https://www.itworldcanada.com/about-us"><div class="tdb-menu-item-text">About Us</div></a></li>
	<li id="menu-item-409765" class="menu-item menu-item-type-post_type menu-item-object-page tdb-menu-item tdb-normal-menu menu-item-409765"><a href="https://www.itworldcanada.com/privacy"><div class="tdb-menu-item-text">Privacy Policy</div></a></li>
	<li id="menu-item-101238" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item tdb-normal-menu menu-item-101238"><a href="http://www.itwc.ca/contact-us.php"><div class="tdb-menu-item-text">Contact Us</div></a></li>
</ul>
</li>
</ul><div class="tdb-menu-items-dropdown"><div class="td-subcat-more"><span class="tdb-menu-item-text">More</span><i class="tdb-menu-more-subicon td-icon-read-down"></i><ul class="td-pulldown-filter-list"></ul></div></div></div></div></div><div class="tdm_block td_block_wrap tdm_block_button tdi_46 tdm-block-button-inline tdm-content-horiz-right td-pb-border-top td_block_template_9"  data-td-block-uid="tdi_46"     >
<style>

/* inline tdc_css att */

.tdi_46{
margin-top:13px !important;
margin-right:10px; !important;
}

</style>
<style>
/* custom css */
.tdm_block.tdm_block_button{
                  margin-bottom: 0;
                }.tdm_block.tdm_block_button .tds-button{
                  line-height: 0;
                }.tdm_block.tdm_block_button.tdm-block-button-inline{
                  display: inline-block;
                }.tdm_block.tdm_block_button.tdm-block-button-full,
                .tdm_block.tdm_block_button.tdm-block-button-full .tdm-btn{
                  display: block;
                }.tdi_46{
                    float: right;
                    clear: none;
                }
</style>
<style>
body .tdi_47:before{
					background-color: #9e2222;
				}
</style><div class="tds-button td-fix-index"><a 
                href="/subscribe/" 
                class="tds-button1 tdm-btn tdm-btn-sm tdi_47" ><span class="tdm-btn-text">SUBSCRIBE</span></a></div></div></div></div></div></div><div id="tdi_48" class="tdc-row"><div class="vc_row tdi_49  wpb_row td-pb-row tdc-row-content-vert-center" >
<style scoped>

/* custom css */
.tdi_49,
                .tdi_49 .tdc-columns{
                    min-height: 0;
                }.tdi_49,
				.tdi_49 .tdc-columns{
				    display: block;
				}.tdi_49 .tdc-columns{
				    width: 100%;
				}@media (min-width: 768px) {
	                .tdi_49 {
	                    margin-left: -14px;
	                    margin-right: -14px;
	                }
	                .tdi_49 .tdc-row-video-background-error,
	                .tdi_49 .vc_column {
	                    padding-left: 14px;
	                    padding-right: 14px;
	                }
                }@media (min-width: 767px) {
                    .tdi_49.tdc-row-content-vert-center,
                    .tdi_49.tdc-row-content-vert-center .tdc-columns {
                        display: flex;
                        align-items: center;
                        flex: 1;
                    }
                    .tdi_49.tdc-row-content-vert-bottom,
                    .tdi_49.tdc-row-content-vert-bottom .tdc-columns {
                        display: flex;
                        align-items: flex-end;
                        flex: 1;
                    }
                    .tdi_49.tdc-row-content-vert-center .td_block_wrap {
                        vertical-align: middle;
                    }
                    .tdi_49.tdc-row-content-vert-bottom .td_block_wrap {
                        vertical-align: bottom;
                    }
                }
/* inline tdc_css att */

.tdi_49{
padding-top:24px !important;
}

.tdi_49 .td_block_wrap{ text-align:left }

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.tdi_49{
padding-top:14px !important;
}
}

</style><div class="vc_column tdi_51  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_51{
                    vertical-align: baseline;
                }.tdi_51 > .wpb_wrapper,
				.tdi_51 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_51 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_51 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_51 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
/* inline tdc_css att */

.tdi_51{
margin-bottom:20px !important;
}

/* phone */
@media (max-width: 767px)
{
.tdi_51{
margin-top:100px !important;
}
}

</style><div class="wpb_wrapper"><div class="td-a-rec td-a-rec-id-header  tdi_52 td_block_template_9">
<style>

/* inline tdc_css att */

.tdi_52{
margin-bottom:0px !important;
}

</style>
<style>
/* custom css */
.tdi_52.td-a-rec{
					text-align: center;
				}.tdi_52 .td-element-style{
					z-index: -1;
				}.tdi_52.td-a-rec-img{
				    text-align: left;
				}.tdi_52.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_52.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><div id=div-gpt-leaderboardros> <script>googletag.cmd.push(function() {googletag.display('div-gpt-leaderboardros');
setInterval(function(){googletag.pubads().refresh([slot_leaderboardros]);}, slot_time);
});</script> 
</div></div></div></div></div></div></div></div>                    </div>
                                <div class="td-header-desktop-sticky-wrap tdc-zone-sticky-invisible tdc-zone-sticky-inactive" style="display: none">
                    <div id="tdi_53" class="tdc-zone"><div class="tdc_zone tdi_54  wpb_row td-pb-row" data-sticky-offset="0" >
<style scoped>

/* custom css */
.tdi_54{
                    min-height: 0;
                }.td-header-desktop-sticky-wrap.td-header-active{
                    opacity: 1;
                }
</style><div id="tdi_55" class="tdc-row"><div class="vc_row tdi_56  wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_56,
                .tdi_56 .tdc-columns{
                    min-height: 0;
                }.tdi_56,
				.tdi_56 .tdc-columns{
				    display: block;
				}.tdi_56 .tdc-columns{
				    width: 100%;
				}
</style><div class="vc_column tdi_58  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_58{
                    vertical-align: baseline;
                }.tdi_58 > .wpb_wrapper,
				.tdi_58 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_58 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_58 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_58 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"></div></div></div></div></div></div>                </div>
            </div>
            
    <div id="tdb-autoload-article" data-autoload="on" data-autoload-org-post-id="469537" data-autoload-type="same_cat_prev" data-autoload-count="3" >
    <style>
        .tdb-autoload-wrap {
            position: relative;
        }
        .tdb-autoload-wrap .tdb-loader-autoload {
            top: auto !important;
            bottom: 50px !important;
        }
        .tdb-autoload-debug {
            display: none;
            width: 1068px;
            margin-right: auto;
            margin-left: auto;
        }
        @media (min-width: 1019px) and (max-width: 1018px) {
            .tdb-autoload-debug {
                width: 740px;
            }
        }
        @media (max-width: 767px) {
            .tdb-autoload-debug {
                display: none;
                width: 100%;
                padding-left: 20px;
                padding-right: 20px;
            }
        }
    </style>

        <div class="td-main-content-wrap td-container-wrap">
            <div class="tdc-content-wrap tdb-autoload-wrap">
                <article id="template-id-454486"
                    class="post-454486 tdb_templates type-tdb_templates status-publish post"                    itemscope itemtype="https://schema.org/Article"                     data-post-url="https://www.itworldcanada.com/article/apache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j/469537"                     data-post-edit-url=""                     data-post-title="Apache issues fifth patch this month to close another bug in Log4j"                >
	                                    <div id="tdi_59" class="tdc-zone"><div class="tdc_zone tdi_60  wpb_row td-pb-row"  >
<style scoped>

/* custom css */
.tdi_60{
                    min-height: 0;
                }
</style><div id="tdi_61" class="tdc-row stretch_row_content td-stretch-content"><div class="vc_row tdi_62  wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_62,
                .tdi_62 .tdc-columns{
                    min-height: 0;
                }.tdi_62,
				.tdi_62 .tdc-columns{
				    display: block;
				}.tdi_62 .tdc-columns{
				    width: 100%;
				}
/* inline tdc_css att */

.tdi_62{
margin-bottom:48px !important;
}

.tdi_62 .td_block_wrap{ text-align:left }

</style><div class="vc_column tdi_64  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_64{
                    vertical-align: baseline;
                }.tdi_64 > .wpb_wrapper,
				.tdi_64 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_64 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_64 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_64 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="vc_row_inner tdi_66  vc_row vc_inner wpb_row td-pb-row absolute_inner_1068 absolute_inner" >
<style scoped>

/* custom css */
.tdi_66{
                    position: absolute !important;
                    top: 0;
                    z-index: 1;
                }.tdi_66,
				.tdi_66 .tdc-inner-columns{
				    display: block;
				}.tdi_66 .tdc-inner-columns{
				    width: 100%;
				}
/* inline tdc_css att */

.tdi_66{
padding-top:20px !important;
width:100% !important;
z-index:1 !important;
}

.tdi_66 .td_block_wrap{ text-align:left }

/* desktop */ @media(min-width: 1141px) { .tdi_66 { 
display:table !important;
} }

</style><div class="vc_column_inner tdi_68  wpb_column vc_column_container tdc-inner-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_68{
                    vertical-align: baseline;
                }.tdi_68 .vc_column-inner > .wpb_wrapper,
				.tdi_68 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    display: block;
				}.tdi_68 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    width: 100%;
				}
</style><div class="vc_column-inner"><div class="wpb_wrapper"></div></div></div></div><div class="vc_row_inner tdi_70  vc_row vc_inner wpb_row td-pb-row absolute_inner_1068 absolute_inner" >
<style scoped>

/* custom css */
.tdi_70{
                    position: absolute !important;
                    top: 0;
                    z-index: 1;
                
                    top: auto;
                    bottom: 0;
                }.tdi_70,
				.tdi_70 .tdc-inner-columns{
				    display: block;
				}.tdi_70 .tdc-inner-columns{
				    width: 100%;
				}
/* inline tdc_css att */

.tdi_70{
width:100% !important;
z-index:1 !important;
}

.tdi_70 .td_block_wrap{ text-align:left }

</style><div class="vc_column_inner tdi_72  wpb_column vc_column_container tdc-inner-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_72{
                    vertical-align: baseline;
                }.tdi_72 .vc_column-inner > .wpb_wrapper,
				.tdi_72 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    display: block;
				}.tdi_72 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    width: 100%;
				}
</style><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td_block_wrap tdb_single_post_views tdi_73 td-pb-border-top td_block_template_9 tdb-post-meta"  data-td-block-uid="tdi_73" >
<style>

/* inline tdc_css att */

.tdi_73{
margin-right:22px !important;
}

</style>
<style>
/* custom css */
.tdb-post-meta{
                  margin-bottom: 16px;
                  color: #444;
                  font-family: 'Open Sans', 'Open Sans Regular', sans-serif;
                  font-size: 11px;
                  font-weight: 400;
                  clear: none;
                  vertical-align: middle;
                  line-height: 1;
                }.tdb-post-meta span,
                .tdb-post-meta i,
                .tdb-post-meta time{
                  vertical-align: middle;
                }.tdb_single_post_views{
                  line-height: 30px;
                }.tdb_single_post_views a{
                  vertical-align: middle;
                }.tdb_single_post_views .tdb-views-icon-svg{
                  position: relative;
                  line-height: 0;
                }.tdb_single_post_views svg{
                  height: auto;
                }.tdb_single_post_views svg,
                 .tdb_single_post_views svg *{
                  fill: #444;
                }.tdi_73{
                    display: inline-block;
                
					color: #ffffff;
				
					font-family:Poppins !important;font-size:13px !important;font-weight:600 !important;letter-spacing:0.8px !important;
				}.tdi_73 i{
                    font-size: 14px;
                
					color: #ffffff;
				}.tdi_73 .tdb-views-icon{
                    margin-right: 5px;
                }.tdi_73 svg,
				.tdi_73 svg *{
					fill: #ffffff;
				
					fill: #ffffff;
				}
</style><div class="tdb-block-inner td-fix-index"><i class="tdb-views-icon td-icon-views"></i><span class="tdb-add-text"></span><span class="td-nr-views-469537">184</span></div></div><div class="td_block_wrap tdb_single_comments_count tdi_74 td-pb-border-top td_block_template_9 tdb-post-meta"  data-td-block-uid="tdi_74" >
<style>
/* custom css */
.tdb_single_comments_count{
                  line-height: 30px;
                }.tdb_single_comments_count .tdb-comm-icon-svg{
                  position: relative;
                  line-height: 0;
                }.tdb_single_comments_count svg{
                  height: auto;
                }.tdb_single_comments_count svg,
                 .tdb_single_comments_count svg *{
                  fill: #444;
                }.tdi_74{
                    display: inline-block;
                
					font-family:Poppins !important;font-size:13px !important;font-weight:600 !important;letter-spacing:0.8px !important;
				}.tdi_74 i{
                    font-size: 10px;
                }.tdi_74 .tdb-comm-icon{
                    margin-right: 5px;
                }.tdi_74 a{
					color: #ffffff;
				}.tdi_74 a svg,
				.tdi_74 a svg *{
					fill: #ffffff;
				
					fill: #ffffff;
				}.tdi_74 a i{
					color: #ffffff;
				}.tdi_74 a:hover{
					color: #ffffff;
				}.tdi_74 a:hover svg,
				.tdi_74 a:hover svg *{
					fill: #ffffff;
				
					fill: #ffffff;
				}.tdi_74 a:hover i{
					color: #ffffff;
				}
</style><div class="tdb-block-inner td-fix-index"><a href="https://www.itworldcanada.com/article/apache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j/469537#respond"><i class="tdb-comm-icon td-icon-comments"></i><span class="tdb-add-text"></span><span>0</span></a></div></div></div></div></div></div></div></div></div></div><div id="tdi_75" class="tdc-row"><div class="vc_row tdi_76 td-ss-row td-scroll-content wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_76,
                .tdi_76 .tdc-columns{
                    min-height: 0;
                }.tdi_76,
				.tdi_76 .tdc-columns{
				    display: block;
				}.tdi_76 .tdc-columns{
				    width: 100%;
				}
</style><div class="vc_column tdi_78  wpb_column vc_column_container tdc-column td-pb-span8">
<style scoped>

/* custom css */
.tdi_78{
                    vertical-align: baseline;
                }.tdi_78 > .wpb_wrapper,
				.tdi_78 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_78 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_78 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_78 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_single_categories tdi_79 td-pb-border-top td_block_template_9 "   data-td-block-uid="tdi_79" >
<style>
/* custom css */
.tdb_single_categories{
                  margin: 0 0 10px 0;
                  line-height: 1;
                  font-family: 'Open Sans', 'Open Sans Regular', sans-serif;
                }.tdb_single_categories a{
                  pointer-events: auto;
                  font-size: 10px;
                  display: inline-block;
                  margin: 0 5px 5px 0;
                  line-height: 1;
                  color: #fff;
                  padding: 3px 6px 4px 6px;
                  white-space: nowrap;
                  position: relative;
                  vertical-align: middle;
                }.tdb_single_categories a:hover .tdb-cat-bg{
                  opacity: 0.9;
                }.tdb_single_categories a:hover .tdb-cat-bg:before{
                  opacity: 1;
                }.tdb-category i:last-of-type{
                  display: none;
                }.tdb-cat-text{
                  display: inline-block;
                  vertical-align: middle;
                  margin-right: 10px;
                }.tdb-cat-sep{
                  font-size: 14px;
                  vertical-align: middle;
                  position: relative;
                }.tdb-cat-sep-svg{
                  line-height: 0;
                }.tdb-cat-sep-svg svg{
                  width: 14px;
                  height: auto;
                }.tdb-cat-bg{
                  position: absolute;
                  background-color: #222;
                  border: 1px solid #222;
                  width: 100%;
                  height: 100%;
                  top: 0;
                  left: 0;
                  z-index: -1;
                }.tdb-cat-bg:before{
                  content: '';
                  width: 100%;
                  height: 100%;
                  left: 0;
                  top: 0;
                  position: absolute;
                  z-index: -1;
                  opacity: 0;
                  -webkit-transition: opacity 0.3s ease;
                  transition: opacity 0.3s ease;
                }.tdb-cat-style2 .tdb-cat-bg{
                  background-color: rgba(34, 34, 34, 0.85);
                }.tdi_79 .tdb-cat-bg{
					border-width: 1px;
				}.tdi_79 .tdb-cat-sep{
					font-size: 14px;
				}.tdi_79 .tdb-cat-text{
					margin-right: 10px;
				}.td-theme-wrap .tdi_79{
					text-align: left;
				}.tdi_79 .tdb-entry-category{
					font-family:Poppins !important;font-size:13px !important;font-weight:600 !important;text-transform:uppercase !important;letter-spacing:0.8px !important;
				}
</style><div class="tdb-category td-fix-index"><a class="tdb-entry-category" href="https://www.itworldcanada.com/category/privacy-and-security" ><span class="tdb-cat-bg" style="background-color:#785548; border-color:#785548;"></span>Privacy &amp; Security</a></div></div><div class="td_block_wrap tdb_title tdi_80 tdb-single-title td-pb-border-top td_block_template_9"  data-td-block-uid="tdi_80" >
<style>
/* custom css */
.tdb_title{
                  margin-bottom: 19px;
                }.tdb_title.tdb-content-horiz-center{
                  text-align: center;
                }.tdb_title.tdb-content-horiz-center .tdb-title-line{
                  margin: 0 auto;
                }.tdb_title.tdb-content-horiz-right{
                  text-align: right;
                }.tdb_title.tdb-content-horiz-right .tdb-title-line{
                  margin-left: auto;
                  margin-right: 0;
                }.tdb-title-text{
                  display: inline-block;
                  position: relative;
                  margin: 0;
                  word-wrap: break-word;
                  font-size: 30px;
                  line-height: 38px;
                  font-weight: 700;
                }.tdb-first-letter{
                  position: absolute;
                  -webkit-user-select: none;
                  user-select: none;
                  pointer-events: none;
                  text-transform: uppercase;
                  color: rgba(0, 0, 0, 0.08);
                  font-size: 6em;
                  font-weight: 300;
                  top: 50%;
                  -webkit-transform: translateY(-50%);
                  transform: translateY(-50%);
                  left: -0.36em;
                  z-index: -1;
                  -webkit-text-fill-color: initial;
                }.tdb-title-line{
                  display: none;
                  position: relative;
                }.tdb-title-line:after{
                  content: '';
                  width: 100%;
                  position: absolute;
                  background-color: #4db2ec;
                  top: 0;
                  left: 0;
                  margin: auto;
                }.tdb-single-title .tdb-title-text{
                  font-size: 41px;
                  line-height: 50px;
                  font-weight: 400;
                }.tdi_80 .tdb-title-line:after{
					height: 2px;
				
					bottom: 40%;
				}.tdi_80 .tdb-title-line{
					height: 50px;
				}.td-theme-wrap .tdi_80{
					text-align: left;
				}.tdi_80 .tdb-first-letter{
					left: -0.36em;
					right: auto;
				
					color: #000000;
				}.tdi_80 .tdb-title-text{
					font-family:Poppins !important;font-size:53px !important;line-height:1.3 !important;font-weight:300 !important;
				}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_80 .tdb-title-text{
					font-family:Poppins !important;font-size:32px !important;line-height:36px !important;font-weight:300 !important;
				}
}

/* phone */
@media (max-width: 767px){
.tdi_80 .tdb-title-text{
					font-family:Poppins !important;font-size:32px !important;line-height:36px !important;font-weight:300 !important;
				}
}
</style><div class="tdb-block-inner td-fix-index"><h1 class="tdb-title-text">Apache issues fifth patch this month to close another bug in Log4j</h1><div></div><div class="tdb-title-line"></div></div></div><div class="td_block_wrap tdb_single_author tdi_82 td-pb-border-top fix-photos td_block_template_9 tdb-post-meta"  data-td-block-uid="tdi_82" >
<style>
/* custom css */
.tdb_single_author{
                  line-height: 30px;
                }.tdb_single_author a{
                  vertical-align: middle;
                }.tdb_single_author .tdb-block-inner{
                  display: flex;
                  align-items: center;
                }.tdb_single_author .tdb-author-name-wrap{
                  display: flex;
                }.tdb_single_author .tdb-author-name{
                  font-weight: 700;
                  margin-right: 3px;
                }.tdb_single_author .tdb-author-by{
                  margin-right: 3px;
                }.tdb_single_author .tdb-author-photo img{
                  display: block;
                }.tdi_82{
                    display: inline-block;
                }.tdi_82 .tdb-author-name-wrap{
                    align-items: baseline;
                }.tdi_82 .avatar{
                    width: 20px;
                    height: 20px;
                
                    margin-right: 6px;
                
                    border-radius: 50%;
                }.tdi_82 .tdb-author-by{
					color: #ffffff;
				
					font-family:Poppins !important;font-size:13px !important;font-weight:600 !important;text-transform:uppercase !important;letter-spacing:0.8px !important;
				}.tdi_82 .tdb-author-name{
					color: #000;
				
					font-family:Poppins !important;font-size:13px !important;font-weight:600 !important;text-transform:uppercase !important;letter-spacing:0.8px !important;
				}
</style><div class="tdb-block-inner td-fix-index"><div class="tdb-author-name-wrap"><span class="tdb-author-by"></span> <a class="tdb-author-name" href="https://www.itworldcanada.com/author/howardsolomon">Howard Solomon</a></div></div></div><div class="td_block_wrap tdb_single_date tdi_83 td-pb-border-top td_block_template_9 tdb-post-meta"  data-td-block-uid="tdi_83" >
<style>

/* inline tdc_css att */

.tdi_83{
margin-right:22px !important;
}

</style>
<style>
/* custom css */
.tdb_single_date{
                  line-height: 30px;
                }.tdb_single_date a{
                  vertical-align: middle;
                }.tdb_single_date .tdb-date-icon-svg{
                  position: relative;
                  line-height: 0;
                }.tdb_single_date svg{
                  height: auto;
                }.tdb_single_date svg,
                 .tdb_single_date svg *{
                  fill: #444;
                }.tdi_83{
                    display: inline-block;
                
                    float: right;
                
					font-family:Poppins !important;font-size:13px !important;font-weight:300 !important;text-transform:uppercase !important;letter-spacing:0.8px !important;
				}.tdi_83 svg{
                    width: 14px;
                }.tdi_83 .tdb-date-icon{
                    margin-right: 5px;
                }
</style><div class="tdb-block-inner td-fix-index"><time class="entry-date updated td-module-date" datetime="2021-12-29T10:46:06-05:00">December 29, 2021</time></div></div> <!-- ./block --><div class="td_block_wrap tdb_single_featured_image tdi_84 tdb-content-horiz-left td-pb-border-top td_block_template_9"  data-td-block-uid="tdi_84" >
<style>
/* custom css */
.tdb_single_featured_image{
                  margin-bottom: 26px;
                }.tdb_single_featured_image.tdb-sfi-stretch{
                  opacity: 0;
                }.tdb_single_featured_image.tdb-sfi-stretch,
                .tdb_single_featured_image .tdb-block-inner{
                  -webkit-transition: all 0.3s ease-in-out;
                  transition: all 0.3s ease-in-out;
                }.tdb_single_featured_image img{
                  display: block;
                  width: 100%;
                }.tdb_single_featured_image video{
                  max-width: 100%;
                }.tdb_single_featured_image .tdb-caption-text{
                  z-index: 1;
                  text-align: left;
                  font-size: 11px;
                  font-style: italic;
                  font-weight: normal;
                  line-height: 17px;
                  color: #444;
                }.tdb_single_featured_image.tdb-content-horiz-center .tdb-caption-text{
                  text-align: center;
                }.tdb_single_featured_image.tdb-content-horiz-right .tdb-caption-text{
                  text-align: right;
                }.tdb-no-featured-img{
                  background-color: #f1f1f1;
                  width: 100%;
                  height: 500px;
                }.tdb-no-featured-audio{
                  height: 59px;
                }.tdi_84 .td-audio-player{
                    font-size: 12px;
                }.tdi_84 .tdb-caption-text{
                    margin: 6px 0 0;
                }.tdi_84:hover .tdb-block-inner:before{
                    opacity: 0;
                }
</style><div class="tdb-block-inner td-fix-index">
                                    <img 
                                        width="420" 
                                        height="280" 
                                        class="entry-thumb" 
                                        src="https://i.itworldcanada.com/wp-content/uploads/2014/11/INSIDE-SLIDE-hands-coding.jpg" srcset="https://i.itworldcanada.com/wp-content/uploads/2014/11/INSIDE-SLIDE-hands-coding.jpg 420w, https://i.itworldcanada.com/wp-content/uploads/2014/11/INSIDE-SLIDE-hands-coding-300x200.jpg 300w, https://i.itworldcanada.com/wp-content/uploads/2014/11/INSIDE-SLIDE-hands-coding-150x100.jpg 150w" sizes="(max-width: 420px) 100vw, 420px" 
                                        alt="Hands on keyboard showing computing code" 
                                        title="INSIDE SLIDE hands coding"
                                    />
                                    </div></div><div class="td_block_wrap tdb_single_post_share tdi_85 td-pb-border-top td_block_template_9"  data-td-block-uid="tdi_85" >
<style>
/* custom css */
.tdb_single_post_share{
                  margin-bottom: 23px;
                }.tdb-share-classic{
                  position: relative;
                  height: 20px;
                  margin-bottom: 15px;
                }
</style><div id="tdi_85" class="td-post-sharing tdb-block td-ps-bg td-ps-padding td-post-sharing-style2 ">
		<style>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</style>

		<div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.itworldcanada.com%2Farticle%2Fapache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j%2F469537" title="Facebook" >
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Apache+issues+fifth+patch+this+month+to+close+another+bug+in+Log4j&url=https%3A%2F%2Fwww.itworldcanada.com%2Farticle%2Fapache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j%2F469537&via=itworldca" title="Twitter" >
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.itworldcanada.com/article/apache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j/469537&title=Apache+issues+fifth+patch+this+month+to+close+another+bug+in+Log4j" title="Linkedin" >
                                        <div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div>
                                        <div class="td-social-but-text">Linkedin</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://www.itworldcanada.com/article/apache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j/469537&title=Apache+issues+fifth+patch+this+month+to+close+another+bug+in+Log4j" title="ReddIt" >
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="mailto:?subject=Apache issues fifth patch this month to close another bug in Log4j&body=https://www.itworldcanada.com/article/apache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j/469537" title="Email" >
                                        <div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
                                        <div class="td-social-but-text">Email</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print" >
                                        <div class="td-social-but-icon"><i class="td-icon-print"></i></div>
                                        <div class="td-social-but-text">Print</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="tdi_85" title="More">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div><div class="td_block_wrap tdb_single_content tdi_86 td-pb-border-top td_block_template_9 td-post-content tagdiv-type"  data-td-block-uid="tdi_86" >
<style>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</style><div class="tdb-block-inner td-fix-index"><p>More than one security researcher predicted the Log4j/Log4Shell vulnerabilities discovered before Christmas won&#8217;t be the last.</p>
<p>They were right.</p>
<p>Apache has issued another security update for the logging library that administrators must now install in their applications. As of Tuesday the latest version of Log4j that should be in systems running Java 8 is 2.17.1.</p>
<p>That&#8217;s the fifth vulnerability revealed since December 9th.</p>
<p>There is no assurance this will be the last to be issued now that security researchers are giving increased scrutiny to the library.</p>
<p>The latest update closes what is officially called a remote code execution vulnerability, designated <a href="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-44832" target="_blank" rel="noopener">CVE-2021-44832</a>, in version 2.17.0 .</p>
<p>Without this patch, an attacker with permission to modify a log4j logging configuration file can construct a malicious configuration using a JDBC Appender with a data source referencing a JNDI URI which can execute remote code. This issue is fixed by limiting JNDI data source names to the Java protocol.</p>
<p>Researchers at Checkmarx say they discovered and reported this latest bug, which is called a deserialization security vulnerability. This vulnerability doesn’t use the now-disabled lookup feature, <a href="https://checkmarx.com/blog/cve-2021-44832-apache-log4j-2-17-0-arbitrary-code-execution-via-jdbcappender-datasource-element/" target="_blank" rel="noopener">they said in a blog</a>. &#8220;The complexity of this vulnerability is higher than the original CVE-2021-44228 since it requires the attacker to have control over the [log4j] configuration (like the ‘logback’ vulnerability <a href="https://nvd.nist.gov/vuln/detail/CVE-2021-42550" target="_blank" rel="noopener">CVE-2021-42550</a>).&#8221;</p>
<p>Unlike logback, says Checkmarx, in log4j there is a feature to load a remote configuration file or to configure the logger through the code. As a result, arbitrary code execution could be achieved with a <a href="https://en.wikipedia.org/wiki/Man-in-the-middle_attack" target="_blank" rel="noreferrer noopener">man-in-the-middle attack</a>, with a user input ending up in a vulnerable configuration variable, or modifying the log4j config file.</p>
<p>Meanwhile the number of organizations hit while running vulnerable versions of log4j continues to climb. <a href="https://www.bleepingcomputer.com/news/security/fintech-firm-hit-by-log4j-hack-refuses-to-pay-5-million-ransom/" target="_blank" rel="noopener">The Bleeping Computer news site reports</a> that the Vietnamese cryptocurrency trading platform ONUS was recently attacked, with a threat actor demanding US$5 million or copied customer data would be published.</p>
<p>After the company&#8217;s refusal to pay the ransom, threat actors put up data of nearly 2 million ONUS customers for sale on forums, the report says.</p>
<p>According to the news report, sometime between December 11th and 13th &#8212; right after the December 9th warnings started going around the world &#8212; threat actors successfully exploited the Log4Shell vulnerability on an ONUS server running the Cyclos payment software.</p>
<p>While Cyclos had issued a patch on December 13th, for ONUS that wasn&#8217;t fast enough.</p>
<p>Infosec pros with systems running log4j have been advised even after patching to assume their applications have been compromised and should scan for signs of intrusion.</p>
<p><a href="https://www.itworldcanada.com/article/five-nations-issue-alert-and-comprehensive-guidance-for-fighting-log4shell-vulnerabilities/469426" target="_blank" rel="noopener">This is a link to the guidance</a> from the cybersecurity agencies of Canada, the U.S., the U.K., Australia and New Zealand.</p>
</div></div><div class="td_block_wrap tdb_single_tags tdi_89 td-pb-border-top td_block_template_9"  data-td-block-uid="tdi_89" >
<style>
/* custom css */
.tdb_single_tags{
                  margin-bottom: 2px;
                  font-family: 'Open Sans', 'Open Sans Regular', sans-serif;
                  font-weight: 600;
                }.tdb_single_tags span,
                .tdb_single_tags a{
                  font-size: 11px;
                }.tdb_single_tags span{
                  text-transform: uppercase;
                }.tdb_single_tags a:hover{
                  background-color: #4db2ec;
                  border-color: #4db2ec;
                  color: #fff;
                }.tdb_single_tags ul{
                  display: inline-block;
                  margin: 0;
                  list-style-type: none;
                  font-size: 0;
                }.tdb_single_tags li{
                  display: inline-block;
                  margin-left: 0;
                }.tdi_89 span{
                    margin-right: 4px;
                
                    padding: 2px 8px 3px;
                
                    color: #fff;
                
                    background-color: #222;
                }.tdi_89 a{
                    margin-right: 4px;
                
                    padding: 1px 7px 2px;
                
                    border: 1px solid #ededed;
                
                    color: #111;
                }

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px){
.tdi_89 a{
                    border: 1px solid #ededed;
                }
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_89 a{
                    border: 1px solid #ededed;
                }
}

/* phone */
@media (max-width: 767px){
.tdi_89 a{
                    border: 1px solid #ededed;
                }
}
</style><div class="tdb-block-inner td-fix-index"><ul class="tdb-tags"><li><span>Tags</span></li><li><a href="https://www.itworldcanada.com/tag/apache">Apache</a></li><li><a href="https://www.itworldcanada.com/tag/di">DI</a></li><li><a href="https://www.itworldcanada.com/tag/patches">patches</a></li><li><a href="https://www.itworldcanada.com/tag/postmedia">postmedia</a></li><li><a href="https://www.itworldcanada.com/tag/security-strategies">security strategies</a></li><li><a href="https://www.itworldcanada.com/tag/top-story">Top Story</a></li></ul></div></div><div class="wpb_wrapper td_block_empty_space td_block_wrap vc_empty_space tdi_91 "  style="height: 22px"></div><div class="wpb_wrapper td_block_separator td_block_wrap vc_separator tdi_93  td_separator_solid td_separator_center"><span style="border-color:#EBEBEB;border-width:1px;width:100%;"></span>
<style scoped>

/* custom css */
.td_block_separator{
                  width: 100%;
                  align-items: center;
                  margin-bottom: 38px;
                  padding-bottom: 10px;
                }.td_block_separator span{
                  position: relative;
                  display: block;
                  margin: 0 auto;
                  width: 100%;
                  height: 1px;
                  border-top: 1px solid #EBEBEB;
                }.td_separator_align_left span{
                  margin-left: 0;
                }.td_separator_align_right span{
                  margin-right: 0;
                }.td_separator_dashed span{
                  border-top-style: dashed;
                }.td_separator_dotted span{
                  border-top-style: dotted;
                }.td_separator_double span{
                  height: 3px;
                  border-bottom: 1px solid #EBEBEB;
                }.td_separator_shadow > span{
                  position: relative;
                  height: 20px;
                  overflow: hidden;
                  border: 0;
                  color: #EBEBEB;
                }.td_separator_shadow > span > span{
                  position: absolute;
                  top: -30px;
                  left: 0;
                  right: 0;
                  margin: 0 auto;
                  height: 13px;
                  width: 98%;
                  border-radius: 100%;
                }
/* inline tdc_css att */

.tdi_93{
margin-bottom:30px !important;
}

/* phone */
@media (max-width: 767px)
{
.tdi_93{
margin-top:-7px !important;
}
}

</style></div><div class="vc_row_inner tdi_95  vc_row vc_inner wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_95{
                    position: relative !important;
                    top: 0;
                    transform: none;
                    -webkit-transform: none;
                }.tdi_95,
				.tdi_95 .tdc-inner-columns{
				    display: block;
				}.tdi_95 .tdc-inner-columns{
				    width: 100%;
				}
</style><div class="vc_column_inner tdi_97  wpb_column vc_column_container tdc-inner-column td-pb-span7">
<style scoped>

/* custom css */
.tdi_97{
                    vertical-align: baseline;
                }.tdi_97 .vc_column-inner > .wpb_wrapper,
				.tdi_97 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    display: block;
				}.tdi_97 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    width: 100%;
				}
</style><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td_block_wrap td_block_text_with_title tdi_98 tagdiv-type td-pb-border-top td_block_template_9"  data-td-block-uid="tdi_98" >
<style>
.td_block_template_9.widget > ul > li {
                margin-left: 0 !important;
            }
            .td_block_template_9 .td-block-title {
                font-size: 17px;
                font-weight: 500;
                margin-top: -10px;
                margin-bottom: 22px;
                line-height: 37px;
                padding: 0;
                position: relative;
                text-align: left;
            }
            .td_block_template_9 .td-block-title:before {
                content: '';
                width: 100%;
                height: 2px;
                position: absolute;
                top: 100%;
                left: 0;
                background-color: #f5f5f5;
            }
            .td_block_template_9 .td-block-title:after {
                content: '';
                width: 50px;
                height: 2px;
                position: absolute;
                top: 100%;
                left: 0;
                margin: auto;
                background-color: #4db2ec;
            }
            .td_block_template_9 .td-block-title > * {
                color: #000;
            }
            .td_block_template_9 .td-subcat-filter {
                line-height: 37px;
                display: table;
            }
            .td_block_template_9 .td-subcat-dropdown {
                line-height: 1;
                position: static;
            }
            .td_block_template_9 .td-subcat-dropdown .td-subcat-more {
                margin-bottom: 0 !important;
            }
            .td_block_template_9 .td-subcat-dropdown ul:after {
                height: 2px !important;
            }
            .td_block_template_9 .td-related-title {
                margin-top: 0 !important;
            }
            .td_block_template_9 .td-related-title a {
                margin-right: 20px;
            }
            @media (max-width: 767px) {
                .td_block_template_9 .td-related-title a{
                    font-size: 15px;
                }
            }
            .td_block_template_9 .td-related-title .td-cur-simple-item {
                color: #4db2ec;
            }
</style>
<style>
/* custom css */
.td_block_text_with_title{
                  margin-bottom: 44px;
                  -webkit-transform: translateZ(0);
                  transform: translateZ(0);
                }.td_block_text_with_title p:last-child{
                  margin-bottom: 0;
                }
</style><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Would you recommend this article?</span></h4></div><div class="td_mod_wrap td-fix-index"><div class="wpulike wpulike-checkmark  wpulike-is-pro" ><div class="wp_ulike_general_class wpulike_up_vote wp_ulike_is_not_liked"><button type="button"
            aria-label="Like Button"
            data-ulike-id="469537" data-ulike-factor="up"
            data-ulike-nonce="2bcf654c60" data-ulike-type="post"
            data-ulike-template="wp-ulike-pro-checkmark" data-ulike-display-likers=""
            data-ulike-likers-style="popover" class="wp_ulike_btn wp_ulike_btn_up  wp_post_up_btn_469537 wp_ulike_put_image"></button><span class="count-box wp_ulike_counter_up" data-ulike-counter-value="0"></span>    </div><div class="wp_ulike_general_class wpulike_down_vote wp_ulike_is_not_liked"><button type="button"
            aria-label="Dislike Button"
            data-ulike-id="469537" data-ulike-factor="down"
            data-ulike-nonce="2bcf654c60" data-ulike-type="post"
            data-ulike-template="wp-ulike-pro-checkmark" data-ulike-display-likers=""
            data-ulike-likers-style="popover" class="wp_ulike_btn wp_ulike_btn_down  wp_post_down_btn_469537 wp_ulike_put_image"></button><span class="count-box wp_ulike_counter_down" data-ulike-counter-value="0"></span>    </div></div>

</div></div></div></div></div><div class="vc_column_inner tdi_100  wpb_column vc_column_container tdc-inner-column td-pb-span5">
<style scoped>

/* custom css */
.tdi_100{
                    vertical-align: baseline;
                }.tdi_100 .vc_column-inner > .wpb_wrapper,
				.tdi_100 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    display: block;
				}.tdi_100 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    width: 100%;
				}
</style><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td_block_wrap td_block_title tdi_101 td-pb-border-top td_block_template_9 td-fix-index"  data-td-block-uid="tdi_101" >
<style>

/* inline tdc_css att */

.tdi_101{
margin-bottom:0px !important;
padding-bottom:0px !important;
}

</style><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Share</span></h4></div></div><div class="td_block_wrap tdb_single_post_share tdi_102 td-pb-border-top td_block_template_9"  data-td-block-uid="tdi_102" ><div id="tdi_102" class="td-post-sharing tdb-block td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.itworldcanada.com%2Farticle%2Fapache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j%2F469537" title="Facebook" >
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Apache+issues+fifth+patch+this+month+to+close+another+bug+in+Log4j&url=https%3A%2F%2Fwww.itworldcanada.com%2Farticle%2Fapache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j%2F469537&via=itworldca" title="Twitter" >
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.itworldcanada.com/article/apache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j/469537&title=Apache+issues+fifth+patch+this+month+to+close+another+bug+in+Log4j" title="Linkedin" >
                                        <div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div>
                                        <div class="td-social-but-text">Linkedin</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://www.itworldcanada.com/article/apache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j/469537&title=Apache+issues+fifth+patch+this+month+to+close+another+bug+in+Log4j" title="ReddIt" >
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="mailto:?subject=Apache issues fifth patch this month to close another bug in Log4j&body=https://www.itworldcanada.com/article/apache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j/469537" title="Email" >
                                        <div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
                                        <div class="td-social-but-text">Email</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print" >
                                        <div class="td-social-but-icon"><i class="td-icon-print"></i></div>
                                        <div class="td-social-but-text">Print</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="tdi_102" title="More">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div></div></div></div></div><div class="wpb_wrapper td_block_wrap vc_raw_html tdi_104 ">
<style scoped>

/* inline tdc_css att */

.tdi_104{
margin-bottom:0px !important;
padding-bottom:0px !important;
}

</style><div class="td-fix-index"><div id="liker-thanks">
	<strong>Thanks for taking the time to let us know what you think of this article!</strong><br>
  We'd love to hear your opinion about this or any other story you read in our publication.  <a href="mailto:jlove@itwc.ca?body=%0A--%0AArticle Link: " ><strong>Click this link to send me a note &rarr;</strong></a><br><br>

<strong>Jim Love</strong>, Chief Content Officer, IT World Canada
	  </div><style>#liker-thanks{display:none; padding:12px; background:#D2DDFF; border:1px solid #0010AA;}</style>
 <script type="text/javascript">
	 
document.getElementsByClassName("wp_ulike_btn_up")[0].addEventListener('click', function () {
  console.log("You finally clicked Up without jQuery - ");
	
	document.getElementById("liker-thanks").style.display = 'block';
});
	 
document.getElementsByClassName("wp_ulike_btn_down")[0].addEventListener('click', function () {
  console.log("You finally clicked Down without jQuery - ");
	document.getElementById("liker-thanks").style.display = 'block';
});	 
</script></div></div><div class="tdb-author-box td_block_wrap tdb_single_author_box tdi_105 tdb-content-vert-top td-pb-border-top td_block_template_9"  data-td-block-uid="tdi_105" >
<style>
/* custom css */
.tdb-author-box .tdb-author-photo,
                .tdb-author-box .tdb-author-info{
                  display: table-cell;
                  vertical-align: top;
                }.tdb-author-box .tdb-author-photo img{
                  display: block;
                }.tdb-author-box .tdb-author-counters span{
                  display: inline-block;
                  background-color: #222;
                  margin: 0 10px 0 0;
                  padding: 5px 10px 4px;
                  font-family: 'Roboto', sans-serif;
                  font-size: 11px;
                  font-weight: 700;
                  line-height: 1;
                  color: #fff;
                }.tdb-author-box .tdb-author-name,
                .tdb-author-box .tdb-author-url{
                  display: block;
                }.tdb-author-box .tdb-author-name{
                  margin: 7px 0 8px;
                  font-family: 'Open Sans', 'Open Sans Regular', sans-serif;
                  font-size: 15px;
                  line-height: 21px;
                  font-weight: 700;
                  color: #222;
                }.tdb-author-box .tdb-author-name:hover{
                  color: #4db2ec;
                }.tdb-author-box .tdb-author-url{
                  margin-bottom: 6px;
                  font-size: 11px;
                  font-style: italic;
                  line-height: 21px;
                  color: #444;
                }.tdb-author-box .tdb-author-url:hover{
                  color: #4db2ec;
                }.tdb-author-box .tdb-author-descr{
                  font-size: 12px;
                }.tdb-author-box .tdb-author-social{
                  margin-top: 4px;
                }.tdb-author-box .tdb-social-item{
                  position: relative;
                  display: inline-block;
                  -webkit-transition: all 0.2s;
                  transition: all 0.2s;
                  text-align: center;
                  -webkit-transform: translateZ(0);
                  transform: translateZ(0);
                }.tdb-author-box .tdb-social-item:last-child{
                  margin-right: 0 !important;
                }.tdb-author-box .tdb-social-item i{
                  color: #000;
                  -webkit-transition: all 0.2s;
                  transition: all 0.2s;
                }.tdb-author-box .tdb-social-item:hover i{
                  color: #000;
                }.tdi_105{
                    padding: 21px;
                
                    border: 1px solid #ededed;
                }.tdi_105 .tdb-author-info{
                    width: auto;
                
                    padding-bottom: 0;
                    padding-left: 21px;
                }.tdi_105 .tdb-author-photo{
                    width: 117px;
                
                    transform: translateZ(0);
                    -webkit-transform: translateZ(0);
                
                    pointer-events: auto;
                }.tdi_105 .tdb-social-item i{
					font-size: 15px;
					vertical-align: middle;
				
					line-height: 15px;
				}.tdi_105 .tdb-social-item i.td-icon-twitter,
				.tdi_105 .tdb-social-item i.td-icon-linkedin,
				.tdi_105 .tdb-social-item i.td-icon-pinterest,
				.tdi_105 .tdb-social-item i.td-icon-blogger,
				.tdi_105 .tdb-social-item i.td-icon-vimeo{
					font-size: 12px;
				}.tdi_105 .tdb-social-item{
					min-width: 15px;
					height: 15px;
				
				    margin: 10px 20px 10px 0;
				}.tdi_105 .tdb-author-name{
					font-family:Poppins !important;
				}.tdi_105 .tdb-author-url{
					font-family:Poppins !important;
				}.tdi_105 .tdb-author-descr{
					font-family:Source Sans Pro !important;
				}.tdi_105 .tdb-author-photo:hover:before{
                    opacity: 0;
                }

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px){
.tdi_105{
                    border: 1px solid #ededed;
                }
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_105{
                    border: 1px solid #ededed;
                }
}

/* phone */
@media (max-width: 767px){
.tdi_105{
                    border: 1px solid #ededed;
                }
}
</style><div class="tdb-block-inner td-fix-index"><a href="https://www.itworldcanada.com/author/howardsolomon" class="tdb-author-photo" title="Howard Solomon"><img src="/wp-content/uploads/userphoto/166.thumbnail.jpg" alt="Howard Solomon" width="100" height="99" class="photo" /></a><div class="tdb-author-info"><a href="https://www.itworldcanada.com/author/howardsolomon" class="tdb-author-name">Howard Solomon</a><div class="tdb-author-descr">Currently a freelance writer, I'm the former editor of ITWorldCanada.com and Computing Canada. An IT journalist since 1997, I've written for several of ITWC's sister publications including ITBusiness.ca and Computer Dealer News. Before that I was a staff reporter at the Calgary Herald and the Brampton (Ont.) Daily Times. I can be reached at hsolomon [@] soloreporter.com</div><div class="tdb-author-social"><a href="http://ca.linkedin.com/pub/howard-solomon/22/5a0/aa4" target="_blank" title="linkedin" class="tdb-social-item"><i class="td-icon-font td-icon-linkedin"></i></a><a href="https://twitter.com/HowardITWC" target="_blank" title="twitter" class="tdb-social-item"><i class="td-icon-font td-icon-twitter"></i></a></div></div></div></div><div class="vc_row_inner tdi_107  vc_row vc_inner wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_107{
                    position: relative !important;
                    top: 0;
                    transform: none;
                    -webkit-transform: none;
                }.tdi_107,
				.tdi_107 .tdc-inner-columns{
				    display: block;
				}.tdi_107 .tdc-inner-columns{
				    width: 100%;
				}
</style><div class="vc_column_inner tdi_109  wpb_column vc_column_container tdc-inner-column td-pb-span6">
<style scoped>

/* custom css */
.tdi_109{
                    vertical-align: baseline;
                }.tdi_109 .vc_column-inner > .wpb_wrapper,
				.tdi_109 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    display: block;
				}.tdi_109 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    width: 100%;
				}
</style><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td-block td-a-rec td-a-rec-id-custom-spot tdi_110 td_block_template_9">
<style>
/* custom css */
.tdi_110.td-a-rec{
					text-align: center;
				}.tdi_110 .td-element-style{
					z-index: -1;
				}
</style><div id=div-gpt-bigbox2ros> <script>googletag.cmd.push(function() {googletag.display('div-gpt-bigbox2ros');
setInterval(function(){googletag.pubads().refresh([slot_bigbox2ros]);}, slot_time);
});</script> 
</div></div></div></div></div><div class="vc_column_inner tdi_112  wpb_column vc_column_container tdc-inner-column td-pb-span6">
<style scoped>

/* custom css */
.tdi_112{
                    vertical-align: baseline;
                }.tdi_112 .vc_column-inner > .wpb_wrapper,
				.tdi_112 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    display: block;
				}.tdi_112 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    width: 100%;
				}
</style><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td_block_wrap tdb_single_next_prev tdi_113 td-pb-border-top td_block_template_9"  data-td-block-uid="tdi_113" >
<style>

/* inline tdc_css att */

.tdi_113{
margin-bottom:43px !important;
}

</style>
<style>
/* custom css */
.tdb_single_next_prev{
                  *zoom: 1;
                }.tdb_single_next_prev:before,
                .tdb_single_next_prev:after{
                  display: table;
                  content: '';
                  line-height: 0;
                }.tdb_single_next_prev:after{
                  clear: both;
                }.tdb-next-post{
                  font-family: 'Roboto', sans-serif;
                  width: 48%;
                  float: left;
                  transform: translateZ(0);
                  -webkit-transform: translateZ(0);
                  min-height: 1px;
                  line-height: 1;
                }.tdb-next-post span{
                  display: block;
                  font-size: 12px;
                  color: #747474;
                  margin-bottom: 7px;
                }.tdb-next-post a{
                  font-size: 15px;
                  color: #222;
                  line-height: 21px;
                  -webkit-transition: color 0.2s ease;
                  transition: color 0.2s ease;
                }.tdb-next-post a:hover{
                  color: #4db2ec;
                }.tdb-post-next{
                  margin-left: 2%;
                  text-align: right;
                }.tdb-post-prev{
                  margin-right: 2%;
                }.tdi_113 .tdb-next-post span{
					font-family:Poppins !important;
				}

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px){

}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){

}

/* phone */
@media (max-width: 767px){

}
</style><div class="tdb-block-inner td-fix-index"><div class="tdb-next-post tdb-next-post-bg tdb-post-prev"><span>Previous article</span><a href="https://www.itworldcanada.com/article/credential-stuffing-attack-spooks-lastpass-users/469549">Credential stuffing attack spooks LastPass users</a></div><div class="tdb-next-post tdb-next-post-bg tdb-post-next"><span>Next article</span><a href="https://www.itworldcanada.com/article/rootkit-in-hpe-server-management-module-can-wipe-hard-drives-report/469555">Rootkit in HPE server management module can wipe hard drives: Report</a></div></div></div></div></div></div></div></div></div><div class="vc_column tdi_115  wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped>

/* custom css */
.tdi_115{
                    vertical-align: baseline;
                }.tdi_115 > .wpb_wrapper,
				.tdi_115 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_115 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_115 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_115 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="td-a-rec td-a-rec-id-sidebar  tdi_116 td_block_template_9">
<style>
/* custom css */
.tdi_116.td-a-rec{
					text-align: center;
				}.tdi_116 .td-element-style{
					z-index: -1;
				}.tdi_116.td-a-rec-img{
				    text-align: left;
				}.tdi_116.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_116.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><div id=div-gpt-bigboxros> <script>googletag.cmd.push(function() {googletag.display('div-gpt-bigboxros');
setInterval(function(){googletag.pubads().refresh([slot_bigboxros]);}, slot_time);
});</script> 
</div></div><div class="td_block_wrap td_flex_block_1 tdi_117 td-pb-border-top td_block_template_9 td_flex_block"  data-td-block-uid="tdi_117" >
<style>
/* custom css */
.tdi_117 .td-image-wrap{
					padding-bottom: 100%;
				}.tdi_117 .entry-thumb{
					background-position: center 50%;
				}.tdi_117 .td-image-container{
				 	flex: 0 0 22%;
				 	width: 22%;
			    
                	display: block; order: 0;
                }.ie10 .tdi_117 .td-image-container,
				.ie11 .tdi_117 .td-image-container{
				 	flex: 0 0 auto;
			    }.tdi_117 .td-module-container{
					flex-direction: row;
				
				    border-color: #eaeaea !important;
				}.ie10 .tdi_117 .td-module-meta-info,
				.ie11 .tdi_117 .td-module-meta-info{
				 	flex: 1;
			    }.tdi_117 .td-module-meta-info{
					padding: 0px 0px 0px 20px;
				
				    display: flex;
				    flex-direction: column;
					justify-content: center;
				
					border-color: #eaeaea;
				}.tdi_117 .td-category-pos-above .td-post-category{
				    align-self: flex-start;
				}.tdi_117 .td_module_wrap{
					width: 100%;
					float: left;
				
					padding-left: 20px;
					padding-right: 20px;
				
					padding-bottom: 16.5px;
					margin-bottom: 16.5px;
				}.tdi_117 .td_block_inner{
					margin-left: -20px;
					margin-right: -20px;
				}.tdi_117 .td-module-container:before{
					bottom: -16.5px;
				
					border-color: #eaeaea;
				}.tdi_117 .entry-thumb,
				.tdi_117 .entry-thumb:before,
				.tdi_117 .entry-thumb:after{
					border-radius: 50%;
				}.tdi_117 .td-post-vid-time{
					display: block;
				}.tdi_117 .td-post-category{
					display: none;
				}.tdi_117 .td-author-photo .avatar{
				    width: 20px;
				    height: 20px;
				
				    margin-right: 6px;
				
				    border-radius: 50%;
				}.tdi_117 .td-excerpt{
					display: none;
				
					column-count: 1;
				
					column-gap: 48px;
				}.tdi_117 .td-audio-player{
					opacity: 1;
					visibility: visible;
					height: auto;
				
					font-size: 13px;
				}.tdi_117 .td-read-more{
					display: none;
				}.tdi_117 .td-author-date{
					display: inline;
				}.tdi_117 .entry-review-stars{
					display: none;
				}.tdi_117 .td-icon-star,
                .tdi_117 .td-icon-star-empty,
                .tdi_117 .td-icon-star-half{
					font-size: 15px;
				}.tdi_117 .td-module-comments{
					display: none;
				}.tdi_117 .td_module_wrap:nth-last-child(1){
					margin-bottom: 0;
					padding-bottom: 0;
				}.tdi_117 .td_module_wrap:nth-last-child(1) .td-module-container:before{
					display: none;
				}.tdi_117 .td-post-author-name a{
					color: #aaaaaa;
				}.tdi_117 .td-post-date,
				.tdi_117 .td-post-author-name span{
					color: #aaaaaa;
				}.tdi_117 .entry-title{
					margin: 0px 0px 5px 0px;
				
					font-size:16px !important;line-height:1.4 !important;
				}.tdi_117 .td-block-title a,
				.tdi_117 .td-block-title span{
					font-family:Poppins !important;font-size:17px !important;text-transform:none !important;
				}html:not([class*='ie']) .tdi_117 .td-module-container:hover .entry-thumb:before{
                    opacity: 0;
                }

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px){
.tdi_117 .td_module_wrap{
					padding-bottom: 16.5px;
					margin-bottom: 16.5px;
				
					padding-bottom: 16.5px !important;
					margin-bottom: 16.5px !important;
				}.tdi_117 .td-module-container:before{
					bottom: -16.5px;
				}.tdi_117 .td_module_wrap:nth-last-child(1){
					margin-bottom: 0 !important;
					padding-bottom: 0 !important;
				}.tdi_117 .td_module_wrap .td-module-container:before{
					display: block !important;
				}.tdi_117 .td_module_wrap:nth-last-child(1) .td-module-container:before{
					display: none !important;
				}
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_117 .td_module_wrap{
					padding-bottom: 16.5px;
					margin-bottom: 16.5px;
				
					padding-bottom: 16.5px !important;
					margin-bottom: 16.5px !important;
				}.tdi_117 .td-module-container:before{
					bottom: -16.5px;
				}.tdi_117 .td_module_wrap:nth-last-child(1){
					margin-bottom: 0 !important;
					padding-bottom: 0 !important;
				}.tdi_117 .td_module_wrap .td-module-container:before{
					display: block !important;
				}.tdi_117 .td_module_wrap:nth-last-child(1) .td-module-container:before{
					display: none !important;
				}
}

/* phone */
@media (max-width: 767px){
.tdi_117 .td_module_wrap{
					padding-bottom: 16.5px;
					margin-bottom: 16.5px;
				
					padding-bottom: 16.5px !important;
					margin-bottom: 16.5px !important;
				}.tdi_117 .td-module-container:before{
					bottom: -16.5px;
				}.tdi_117 .td_module_wrap:nth-last-child(1){
					margin-bottom: 0 !important;
					padding-bottom: 0 !important;
				}.tdi_117 .td_module_wrap .td-module-container:before{
					display: block !important;
				}.tdi_117 .td_module_wrap:nth-last-child(1) .td-module-container:before{
					display: none !important;
				}
}
</style><script>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</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Related Tech News</span></h4></div><div id=tdi_117 class="td_block_inner td-mc1-wrap">
        <div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack ">
            <div class="td-module-container td-category-pos-image">
                                    <div class="td-image-container">
                                                <div class="td-module-thumb"><a href="https://www.itworldcanada.com/article/rootkit-in-hpe-server-management-module-can-wipe-hard-drives-report/469555" rel="bookmark" class="td-image-wrap " title="Rootkit in HPE server management module can wipe hard drives: Report" ><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://i.itworldcanada.com/wp-content/uploads/2020/11/GettyImages-1185282377.jpg"  ></span></a></div>                                            </div>
                
                <div class="td-module-meta-info">
                    
                    <h3 class="entry-title td-module-title"><a href="https://www.itworldcanada.com/article/rootkit-in-hpe-server-management-module-can-wipe-hard-drives-report/469555" rel="bookmark" title="Rootkit in HPE server management module can wipe hard drives: Report">Rootkit in HPE server management module can wipe hard drives: Report</a></h3>
                    
                                            <div class="td-editor-date">
                            
                                                            <span class="td-author-date">
                                                                        <span class="td-post-author-name"><a href="https://www.itworldcanada.com/author/howardsolomon">Howard Solomon</a> <span>-</span> </span>                                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-12-29T13:26:38-05:00" >December 29, 2021</time></span>                                                                                                        </span>
                                                    </div>
                    
                    
                    
                                    </div>
            </div>
        </div>

        
        <div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack ">
            <div class="td-module-container td-category-pos-image">
                                    <div class="td-image-container">
                                                <div class="td-module-thumb"><a href="https://www.itworldcanada.com/article/credential-stuffing-attack-spooks-lastpass-users/469549" rel="bookmark" class="td-image-wrap " title="Credential stuffing attack spooks LastPass users" ><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://i.itworldcanada.com/wp-content/uploads/2014/05/Password-graphic-SHUTTERSTOCK-150x60.jpg"  ></span></a></div>                                            </div>
                
                <div class="td-module-meta-info">
                    
                    <h3 class="entry-title td-module-title"><a href="https://www.itworldcanada.com/article/credential-stuffing-attack-spooks-lastpass-users/469549" rel="bookmark" title="Credential stuffing attack spooks LastPass users">Credential stuffing attack spooks LastPass users</a></h3>
                    
                                            <div class="td-editor-date">
                            
                                                            <span class="td-author-date">
                                                                        <span class="td-post-author-name"><a href="https://www.itworldcanada.com/author/howardsolomon">Howard Solomon</a> <span>-</span> </span>                                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-12-29T10:37:27-05:00" >December 29, 2021</time></span>                                                                                                        </span>
                                                    </div>
                    
                    
                    
                                    </div>
            </div>
        </div>

        
        <div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack ">
            <div class="td-module-container td-category-pos-image">
                                    <div class="td-image-container">
                                                <div class="td-module-thumb"><a href="https://www.itworldcanada.com/article/cyber-security-today-dec-29-2021-how-hackers-stole-data-on-113000-customers-from-a-canadian-bank/469465" rel="bookmark" class="td-image-wrap " title="Cyber Security Today, Dec. 29, 2021 &#8211; How hackers stole data on 113,000 customers from a Canadian bank" ><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://i.itworldcanada.com/wp-content/uploads/2021/03/cyber-security-today-text-middle2-150x150.png"  ></span></a></div>                                            </div>
                
                <div class="td-module-meta-info">
                    
                    <h3 class="entry-title td-module-title"><a href="https://www.itworldcanada.com/article/cyber-security-today-dec-29-2021-how-hackers-stole-data-on-113000-customers-from-a-canadian-bank/469465" rel="bookmark" title="Cyber Security Today, Dec. 29, 2021 &#8211; How hackers stole data on 113,000 customers from a Canadian bank">Cyber Security Today, Dec. 29, 2021 &#8211; How hackers stole data on...</a></h3>
                    
                                            <div class="td-editor-date">
                            
                                                            <span class="td-author-date">
                                                                        <span class="td-post-author-name"><a href="https://www.itworldcanada.com/author/howardsolomon">Howard Solomon</a> <span>-</span> </span>                                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-12-29T07:49:16-05:00" >December 29, 2021</time></span>                                                                                                        </span>
                                                    </div>
                    
                    
                    
                                    </div>
            </div>
        </div>

        
        <div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack ">
            <div class="td-module-container td-category-pos-image">
                                    <div class="td-image-container">
                                                <div class="td-module-thumb"><a href="https://www.itworldcanada.com/article/beware-of-two-stage-malware-attacks-says-sophos/469491" rel="bookmark" class="td-image-wrap " title="Beware of two-stage malware attacks, says Sophos" ><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://i.itworldcanada.com/wp-content/uploads/2016/01/FEATURE-predictions-crystal-ball-THINKSTOCK-150x63.jpg"  ></span></a></div>                                            </div>
                
                <div class="td-module-meta-info">
                    
                    <h3 class="entry-title td-module-title"><a href="https://www.itworldcanada.com/article/beware-of-two-stage-malware-attacks-says-sophos/469491" rel="bookmark" title="Beware of two-stage malware attacks, says Sophos">Beware of two-stage malware attacks, says Sophos</a></h3>
                    
                                            <div class="td-editor-date">
                            
                                                            <span class="td-author-date">
                                                                        <span class="td-post-author-name"><a href="https://www.itworldcanada.com/author/howardsolomon">Howard Solomon</a> <span>-</span> </span>                                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-12-28T14:43:07-05:00" >December 28, 2021</time></span>                                                                                                        </span>
                                                    </div>
                    
                    
                    
                                    </div>
            </div>
        </div>

        
        <div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack ">
            <div class="td-module-container td-category-pos-image">
                                    <div class="td-image-container">
                                                <div class="td-module-thumb"><a href="https://www.itworldcanada.com/article/cyber-security-today-year-in-review-2021-edition-podcast/469462" rel="bookmark" class="td-image-wrap " title="Cyber Security Today, Year in Review 2021 edition podcast" ><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://i.itworldcanada.com/wp-content/uploads/2021/03/cyber-security-today-text-middle2-150x150.png"  ></span></a></div>                                            </div>
                
                <div class="td-module-meta-info">
                    
                    <h3 class="entry-title td-module-title"><a href="https://www.itworldcanada.com/article/cyber-security-today-year-in-review-2021-edition-podcast/469462" rel="bookmark" title="Cyber Security Today, Year in Review 2021 edition podcast">Cyber Security Today, Year in Review 2021 edition podcast</a></h3>
                    
                                            <div class="td-editor-date">
                            
                                                            <span class="td-author-date">
                                                                        <span class="td-post-author-name"><a href="https://www.itworldcanada.com/author/howardsolomon">Howard Solomon</a> <span>-</span> </span>                                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-12-27T07:37:00-05:00" >December 27, 2021</time></span>                                                                                                        </span>
                                                    </div>
                    
                    
                    
                                    </div>
            </div>
        </div>

        </div></div><div class="td-a-rec td-a-rec-id-custom_ad_1  tdi_118 td_block_template_9">
<style>
/* custom css */
.tdi_118.td-a-rec{
					text-align: center;
				}.tdi_118 .td-element-style{
					z-index: -1;
				}
</style><div id=div-gpt-skybox> <script>googletag.cmd.push(function() {googletag.display('div-gpt-skybox');
setInterval(function(){googletag.pubads().refresh([slot_skybox]);}, slot_time);
});</script> 
</div></div></div></div></div></div></div></div>                    <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Howard Solomon"></span><meta itemprop="datePublished" content="2021-12-29T10:46:06-05:00"><meta itemprop="dateModified" content="2021-12-29T10:46:06-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.itworldcanada.com/article/apache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j/469537"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i.itworldcanada.com/wp-content/uploads/2021/06/itworld_pride.png"></span><meta itemprop="name" content="IT World Canada"></span><meta itemprop="headline" content="Apache issues fifth patch this month to close another bug in Log4j"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i.itworldcanada.com/wp-content/uploads/2014/11/INSIDE-SLIDE-hands-coding.jpg"><meta itemprop="width" content="420"><meta itemprop="height" content="280"></span>                </article>
            </div>
        </div>
        
    </div> <!-- #tdb-autoload-article -->

<!-- Instagram -->
    <div class="td-footer-template-wrap" style="position: relative">
                <div class="td-footer-wrap ">
            <div id="tdi_119" class="tdc-zone"><div class="tdc_zone tdi_120  wpb_row td-pb-row tdc-element-style"  >
<style scoped>

/* custom css */
.tdi_120{
                    min-height: 0;
                }
/* inline tdc_css att */

.tdi_120{
position:relative;
}

</style>
<div class="tdi_119_rand_style td-element-style" ><style>
.tdi_119_rand_style{
background-color:#111111 !important;
}
 </style></div><div id="tdi_121" class="tdc-row stretch_row"><div class="vc_row tdi_122  wpb_row td-pb-row tdc-element-style" >
<style scoped>

/* custom css */
.tdi_122,
                .tdi_122 .tdc-columns{
                    min-height: 0;
                }.tdi_122,
				.tdi_122 .tdc-columns{
				    display: block;
				}.tdi_122 .tdc-columns{
				    width: 100%;
				}
/* inline tdc_css att */

.tdi_122{
position:relative;
}

.tdi_122 .td_block_wrap{ text-align:left }

</style>
<div class="tdi_121_rand_style td-element-style" ><style>
.tdi_121_rand_style{
background-color:#ffffff !important;
}
 </style></div><div class="vc_column tdi_124  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_124{
                    vertical-align: baseline;
                }.tdi_124 > .wpb_wrapper,
				.tdi_124 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_124 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_124 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_124 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="td-block td-a-rec td-a-rec-id-custom-spot tdi_125 td_block_template_9">
<style>
/* custom css */
.tdi_125.td-a-rec{
					text-align: center;
				}.tdi_125 .td-element-style{
					z-index: -1;
				}
</style><div id='div-gpt-footer'> 
<script>googletag.cmd.push(function() {googletag.display('div-gpt-footer');
setInterval(function(){googletag.pubads().refresh([slot_footer]);}, slot_time);
});</script>
 </div>

<div id='div-gpt-inter'> <script type='text/javascript'>googletag.cmd.push(function() {googletag.display('div-gpt-inter');});</script> </div></div></div></div></div></div><div id="tdi_126" class="tdc-row stretch_row"><div class="vc_row tdi_127  wpb_row td-pb-row tdc-element-style" >
<style scoped>

/* custom css */
.tdi_127,
                .tdi_127 .tdc-columns{
                    min-height: 0;
                }.tdi_127,
				.tdi_127 .tdc-columns{
				    display: block;
				}.tdi_127 .tdc-columns{
				    width: 100%;
				}
/* inline tdc_css att */

.tdi_127{
padding-top:54px !important;
padding-bottom:20px !important;
position:relative;
}

.tdi_127 .td_block_wrap{ text-align:left }

/* phone */
@media (max-width: 767px)
{
.tdi_127{
padding-top:40px !important;
}
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.tdi_127{
padding-top:44px !important;
}
}

</style>
<div class="tdi_126_rand_style td-element-style" ><div class="td-element-style-before"><style>
.tdi_126_rand_style > .td-element-style-before {
content:'' !important;
width:100% !important;
height:100% !important;
position:absolute !important;
top:0 !important;
left:0 !important;
display:block !important;
z-index:0 !important;
opacity:0.1 !important;
background-size:cover !important;
background-position:center top !important;
}
</style></div><style>
.tdi_126_rand_style{
background-color:#111111 !important;
}
 </style></div><div class="vc_column tdi_129  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_129{
                    vertical-align: baseline;
                }.tdi_129 > .wpb_wrapper,
				.tdi_129 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_129 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_129 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_129 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="td_block_wrap td_block_title tdi_130 td-pb-border-top td_block_template_9 td-fix-index"  data-td-block-uid="tdi_130" >
<style>
.tdi_130 .td-block-title > * {
                color: #ffffff !important;
            }

            
            .tdi_130 .td_module_wrap:hover .entry-title a,
            .tdi_130 .td-pulldown-filter-link:hover,
            .tdi_130 .td-subcat-item a:hover,
            .tdi_130 .td-cur-simple-item,
            .tdi_130 .td_quote_on_blocks,
            .tdi_130 .td-opacity-cat .td-post-category:hover,
            .tdi_130 .td-opacity-read .td-read-more a:hover,
            .tdi_130 .td-opacity-author .td-post-author-name a:hover,
            .tdi_130 .td-instagram-user a,
            .tdi_130 .td-subcat-dropdown:hover .td-subcat-more span,
            .tdi_130 .td-subcat-dropdown:hover .td-subcat-more i {
                color: #dd3333 !important;
            }

            .tdi_130 .td-next-prev-wrap a:hover,
            .tdi_130 .td-load-more-wrap a:hover {
                background-color: #dd3333 !important;
                border-color: #dd3333 !important;
            }

            .tdi_130 .td-read-more a,
            .tdi_130 .td-weather-information:before,
            .tdi_130 .td-weather-week:before,
            .tdi_130 .td-exchange-header:before,
            .td-footer-wrapper .tdi_130 .td-post-category,
            .tdi_130 .td-post-category:hover,
            .tdi_130 .td-subcat-dropdown ul:after,
            .tdi_130 .td-block-title:after {
                background-color: #dd3333 !important;
            }
</style><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Popular Stories This Week</span></h4></div></div><div class="td_block_wrap td_flex_block_4 tdi_131 td-pb-border-top td_block_template_9 td_flex_block"  data-td-block-uid="tdi_131" >
<style>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</style><script>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</script><div class="td-block-title-wrap"></div><div id=tdi_131 class="td_block_inner td-mc1-wrap">
        <div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack ">
            <div class="td-module-container td-category-pos-image">
                                    <div class="td-image-container">
                        <a href="https://www.itworldcanada.com/category/cloud" class="td-post-category">Cloud</a>                        <div class="td-module-thumb"><a href="https://www.itworldcanada.com/article/amazon-web-services-hit-with-another-outage-many-services-now-restored/469344" rel="bookmark" class="td-image-wrap " title="Amazon Web Services hit with another outage, many services now restored" ><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://i.itworldcanada.com/wp-content/uploads/2021/12/GettyImages-912000448-696x392.jpg"  ></span></a></div>                                            </div>
                
                <div class="td-module-meta-info">
                    
                    <h3 class="entry-title td-module-title"><a href="https://www.itworldcanada.com/article/amazon-web-services-hit-with-another-outage-many-services-now-restored/469344" rel="bookmark" title="Amazon Web Services hit with another outage, many services now restored">Amazon Web Services hit with another outage, many services now restored</a></h3>
                    
                    
                    
                    
                                    </div>
            </div>
        </div>

        
        <div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack ">
            <div class="td-module-container td-category-pos-image">
                                    <div class="td-image-container">
                        <a href="https://www.itworldcanada.com/category/privacy-and-security" class="td-post-category">Privacy &amp; Security</a>                        <div class="td-module-thumb"><a href="https://www.itworldcanada.com/article/apache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j/469537" rel="bookmark" class="td-image-wrap " title="Apache issues fifth patch this month to close another bug in Log4j" ><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://i.itworldcanada.com/wp-content/uploads/2014/11/INSIDE-SLIDE-hands-coding.jpg"  ></span></a></div>                                            </div>
                
                <div class="td-module-meta-info">
                    
                    <h3 class="entry-title td-module-title"><a href="https://www.itworldcanada.com/article/apache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j/469537" rel="bookmark" title="Apache issues fifth patch this month to close another bug in Log4j">Apache issues fifth patch this month to close another bug in Log4j</a></h3>
                    
                    
                    
                    
                                    </div>
            </div>
        </div>

        
        <div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack ">
            <div class="td-module-container td-category-pos-image">
                                    <div class="td-image-container">
                        <a href="https://www.itworldcanada.com/category/emerging-tech" class="td-post-category">Emerging Tech</a>                        <div class="td-module-thumb"><a href="https://www.itworldcanada.com/article/ces-2022-exhibitors-opting-out-over-omicron-concerns-but-cta-says-the-show-will-go-on/469360" rel="bookmark" class="td-image-wrap " title="CES 2022 exhibitors opting out over Omicron concerns, but CTA says the show will go on" ><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://i.itworldcanada.com/wp-content/uploads/2021/12/GettyImages-614972576-696x464.jpg"  ></span></a></div>                                            </div>
                
                <div class="td-module-meta-info">
                    
                    <h3 class="entry-title td-module-title"><a href="https://www.itworldcanada.com/article/ces-2022-exhibitors-opting-out-over-omicron-concerns-but-cta-says-the-show-will-go-on/469360" rel="bookmark" title="CES 2022 exhibitors opting out over Omicron concerns, but CTA says the show will go on">CES 2022 exhibitors opting out over Omicron concerns, but CTA says the show will go on</a></h3>
                    
                    
                    
                    
                                    </div>
            </div>
        </div>

        
        <div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack ">
            <div class="td-module-container td-category-pos-image">
                                    <div class="td-image-container">
                        <a href="https://www.itworldcanada.com/category/cloud" class="td-post-category">Cloud</a>                        <div class="td-module-thumb"><a href="https://www.itworldcanada.com/article/vancouver-software-company-to-acquire-australia-based-link-group-for-ca3-2-billion/469361" rel="bookmark" class="td-image-wrap " title="Vancouver software company to acquire Australia-based Link Group for CA$3.2 billion" ><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://i.itworldcanada.com/wp-content/uploads/2021/12/GettyImages-531067704.jpg"  ></span></a></div>                                            </div>
                
                <div class="td-module-meta-info">
                    
                    <h3 class="entry-title td-module-title"><a href="https://www.itworldcanada.com/article/vancouver-software-company-to-acquire-australia-based-link-group-for-ca3-2-billion/469361" rel="bookmark" title="Vancouver software company to acquire Australia-based Link Group for CA$3.2 billion">Vancouver software company to acquire Australia-based Link Group for CA$3.2 billion</a></h3>
                    
                    
                    
                    
                                    </div>
            </div>
        </div>

        
        <div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack ">
            <div class="td-module-container td-category-pos-image">
                                    <div class="td-image-container">
                        <a href="https://www.itworldcanada.com/category/privacy-and-security" class="td-post-category">Privacy &amp; Security</a>                        <div class="td-module-thumb"><a href="https://www.itworldcanada.com/article/beware-of-two-stage-malware-attacks-says-sophos/469491" rel="bookmark" class="td-image-wrap " title="Beware of two-stage malware attacks, says Sophos" ><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://i.itworldcanada.com/wp-content/uploads/2016/01/FEATURE-predictions-crystal-ball-THINKSTOCK.jpg"  ></span></a></div>                                            </div>
                
                <div class="td-module-meta-info">
                    
                    <h3 class="entry-title td-module-title"><a href="https://www.itworldcanada.com/article/beware-of-two-stage-malware-attacks-says-sophos/469491" rel="bookmark" title="Beware of two-stage malware attacks, says Sophos">Beware of two-stage malware attacks, says Sophos</a></h3>
                    
                    
                    
                    
                                    </div>
            </div>
        </div>

        </div></div></div></div></div></div><div id="tdi_132" class="tdc-row stretch_row_content td-stretch-content"><div class="vc_row tdi_133  wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_133,
                .tdi_133 .tdc-columns{
                    min-height: 0;
                }.tdi_133,
				.tdi_133 .tdc-columns{
				    display: block;
				}.tdi_133 .tdc-columns{
				    width: 100%;
				}
</style><div class="vc_column tdi_135  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_135{
                    vertical-align: baseline;
                
				    flex-grow: 1;
				}.tdi_135 > .wpb_wrapper,
				.tdi_135 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_135 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_135 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_135 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
/* inline tdc_css att */

.tdi_135{
position:relative;
}

/* desktop */ @media(min-width: 1141px) { .tdi_135 { 
display:block !important;
} }

</style>
<div class="tdi_134_rand_style td-element-style" ><style>
.tdi_134_rand_style{
background-color:#000000 !important;
}
 </style></div><div class="wpb_wrapper"><div class="wpb_wrapper td_block_wrap vc_raw_html tdi_137 ">
<style scoped>

/* inline tdc_css att */

.tdi_137{
margin-bottom:0px !important;
padding-bottom:0px !important;
position:relative;
}

</style>
<div class="tdi_136_rand_style td-element-style" ><style>
.tdi_136_rand_style{
background-color:#111111 !important;
}
 </style></div><div class="td-fix-index"><iframe
src=https://www.itworldcanada.com/subscribe/daily.php?theme=light class=subframe scrolling=auto title="Subscribe to IT World Canada"></iframe></div></div><div class="wpb_wrapper td_block_empty_space td_block_wrap vc_empty_space tdi_139 "  style="height: 32px">
<style scoped>

/* inline tdc_css att */

.tdi_139{
position:relative;
}

</style>
<div class="tdi_138_rand_style td-element-style" ><style>
.tdi_138_rand_style{
background-color:#111111 !important;
}
 </style></div></div></div></div></div></div><div id="tdi_140" class="tdc-row stretch_row"><div class="vc_row tdi_141  wpb_row td-pb-row tdc-element-style" >
<style scoped>

/* custom css */
.tdi_141,
                .tdi_141 .tdc-columns{
                    min-height: 0;
                }.tdi_141,
				.tdi_141 .tdc-columns{
				    display: block;
				}.tdi_141 .tdc-columns{
				    width: 100%;
				}
/* inline tdc_css att */

.tdi_141{
position:relative;
}

.tdi_141 .td_block_wrap{ text-align:left }

</style>
<div class="tdi_140_rand_style td-element-style" ><style>
.tdi_140_rand_style{
background-color:#111111 !important;
}
 </style></div><div class="vc_column tdi_143  wpb_column vc_column_container tdc-column td-pb-span8">
<style scoped>

/* custom css */
.tdi_143{
                    vertical-align: baseline;
                }.tdi_143 > .wpb_wrapper,
				.tdi_143 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_143 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_143 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_143 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="tdm_block td_block_wrap tdm_block_inline_text tdi_144 td-pb-border-top td_block_template_9"  data-td-block-uid="tdi_144" >
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_144{
justify-content:center !important;
text-align:center !important;
}
}

</style>
<style>
/* custom css */
.tdm_block.tdm_block_inline_text{
                  margin-bottom: 0;
                  vertical-align: top;
                }.tdm_block.tdm_block_inline_text .tdm-descr{
                  margin-bottom: 0;
                  -webkit-transform: translateZ(0);
                  transform: translateZ(0);
                }.tdc-row-content-vert-center .tdm-inline-text-yes{
                  vertical-align: middle;
                }.tdc-row-content-vert-bottom .tdm-inline-text-yes{
                  vertical-align: bottom;
                }.tdi_144{
                    text-align: left !important;
                }.tdi_144 .tdm-descr{
                    color: #eaeaea;
                
					font-family:Source Sans Pro !important;font-size:15px !important;line-height:1.6 !important;font-weight:400 !important;
				}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_144 .tdm-descr{
					font-family:Source Sans Pro !important;font-size:13px !important;line-height:1.6 !important;font-weight:400 !important;
				}
}
</style><p class="tdm-descr">ITWorldcanada.com is the leading Canadian online resource for IT professionals working in medium to large enterprises. IT World Canada creates daily news content, produces a daily newsletter and features IT professionals who blog on topics of industry interest.</p></div><div class="wpb_wrapper td_block_empty_space td_block_wrap vc_empty_space tdi_146 "  style="height: 32px"></div></div></div><div class="vc_column tdi_148  wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped>

/* custom css */
.tdi_148{
                    vertical-align: baseline;
                }.tdi_148 > .wpb_wrapper,
				.tdi_148 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_148 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_148 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_148 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="tdm_block td_block_wrap tdm_block_column_title tdi_149 tdm-content-horiz-center td-pb-border-top td_block_template_9"  data-td-block-uid="tdi_149" >
<style>

/* inline tdc_css att */

.tdi_149{
margin-bottom:-30px !important;
padding-bottom:0px !important;
}

/* phone */
@media (max-width: 767px)
{
.tdi_149{
justify-content:center !important;
text-align:center !important;
}
}

</style>
<style>
/* custom css */
.tdm_block_column_title{
                  margin-bottom: 0;
                  display: inline-block;
                  width: 100%;
                }
</style><div class="td-block-row"><div class="td-block-span12 tdm-col">
<style>
body .tdi_150 .tdm-title{
					color: #ffffff;
				}.tdi_150 .tdm-title{
					font-size:18px !important;line-height:1 !important;font-weight:700 !important;
				}
</style><div class="tds-title tds-title1 td-fix-index tdi_150"><h3 class="tdm-title tdm-title-md">FOLLOW US</h3></div></div></div></div><div class="tdm_block td_block_wrap tdm_block_socials tdi_151 tdm-content-horiz-center td-pb-border-top td_block_template_9"  data-td-block-uid="tdi_151" >
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_151{
justify-content:center !important;
text-align:center !important;
}
}

</style>
<style>
.tdi_152 .tdm-social-item i{
					font-size: 14px;
					vertical-align: middle;
				
					line-height: 39.2px;
				}.tdi_152 .tdm-social-item i.td-icon-twitter,
				.tdi_152 .tdm-social-item i.td-icon-linkedin,
				.tdi_152 .tdm-social-item i.td-icon-pinterest,
				.tdi_152 .tdm-social-item i.td-icon-blogger,
				.tdi_152 .tdm-social-item i.td-icon-vimeo{
					font-size: 11.2px;
				}.tdi_152 .tdm-social-item{
					width: 39.2px;
					height: 39.2px;
				
				    margin: 5px 10px 5px 0;
				
					background: rgba(255,255,255,0.03);
				}.tdi_152 .tdm-social-item-wrap:last-child .tdm-social-item{
				    margin-right: 0 !important;
				}.tdi_152 .tdm-social-item i,
				.tds-team-member2 .tdi_152.tds-social4 .tdm-social-item i{
					color: #ffffff;
				}.tdi_152 .tdm-social-item-wrap:hover i,
				body .tds-team-member2 .tdi_152.tds-social4 .tdm-social-item-wrap:hover i{
					color: #dd3333;
				}body .tdi_152 .tdm-social-item{
				    border: 1px solid rgba(255,255,255,0.03);
				}.tdi_152 .tdm-social-text{
					display: none;
				
					margin-left: 2px;
				
					margin-right: 18px;
				}

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px){
body .tdi_152 .tdm-social-item{
				    border: 1px solid rgba(255,255,255,0.03);
				}
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_152 .tdm-social-item{
					width: 35px;
					height: 35px;
				}.tdi_152 .tdm-social-item i{
					line-height: 35px;
				}body .tdi_152 .tdm-social-item{
				    border: 1px solid rgba(255,255,255,0.03);
				}
}

/* phone */
@media (max-width: 767px){
body .tdi_152 .tdm-social-item{
				    border: 1px solid rgba(255,255,255,0.03);
				}
}
</style><div class="tdm-social-wrapper tds-social4 tdi_152"><div class="tdm-social-item-wrap"><a href="https://www.facebook.com/ITWorldCa"  title="Facebook" class="tdm-social-item"><i class="td-icon-font td-icon-facebook"></i></a><a href="https://www.facebook.com/ITWorldCa" class="tdm-social-text">Facebook</a></div><div class="tdm-social-item-wrap"><a href="https://www.linkedin.com/company/itworldcanada/"  title="Linkedin" class="tdm-social-item"><i class="td-icon-font td-icon-linkedin"></i></a><a href="https://www.linkedin.com/company/itworldcanada/" class="tdm-social-text">Linkedin</a></div><div class="tdm-social-item-wrap"><a href="https://www.itworldcanada.com/feed"  title="RSS" class="tdm-social-item"><i class="td-icon-font td-icon-rss"></i></a><a href="https://www.itworldcanada.com/feed" class="tdm-social-text">RSS</a></div><div class="tdm-social-item-wrap"><a href="https://twitter.com/intent/user?screen_name=itworldca"  title="Twitter" class="tdm-social-item"><i class="td-icon-font td-icon-twitter"></i></a><a href="https://twitter.com/intent/user?screen_name=itworldca" class="tdm-social-text">Twitter</a></div><div class="tdm-social-item-wrap"><a href="https://www.youtube.com/channel/UCvlbuIiCz691utVrZYbYhIA"  title="Youtube" class="tdm-social-item"><i class="td-icon-font td-icon-youtube"></i></a><a href="https://www.youtube.com/channel/UCvlbuIiCz691utVrZYbYhIA" class="tdm-social-text">Youtube</a></div></div></div></div></div></div></div><div id="tdi_153" class="tdc-row stretch_row"><div class="vc_row tdi_154  wpb_row td-pb-row tdc-element-style" >
<style scoped>

/* custom css */
.tdi_154,
                .tdi_154 .tdc-columns{
                    min-height: 0;
                }.tdi_154,
				.tdi_154 .tdc-columns{
				    display: block;
				}.tdi_154 .tdc-columns{
				    width: 100%;
				}
/* inline tdc_css att */

.tdi_154{
position:relative;
}

.tdi_154 .td_block_wrap{ text-align:left }

/* phone */
@media (max-width: 767px)
{
.tdi_154{
padding-top:6px !important;
padding-bottom:6px !important;
}
}

</style>
<div class="tdi_153_rand_style td-element-style" ><style>
.tdi_153_rand_style{
background-color:#515151 !important;
}
 </style></div><div class="vc_column tdi_156  wpb_column vc_column_container tdc-column td-pb-span6">
<style scoped>

/* custom css */
.tdi_156{
                    vertical-align: baseline;
                }.tdi_156 > .wpb_wrapper,
				.tdi_156 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_156 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_156 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_156 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="tdm_block td_block_wrap tdm_block_inline_text tdi_157 td-pb-border-top td_block_template_9"  data-td-block-uid="tdi_157" >
<style>

/* inline tdc_css att */

.tdi_157{
margin-top:2px !important;
margin-bottom:0px !important;
padding-top:8px !important;
padding-bottom:8px !important;
}

/* phone */
@media (max-width: 767px)
{
.tdi_157{
margin-top:0px !important;
justify-content:center !important;
text-align:center !important;
}
}

</style>
<style>
/* custom css */
.tdi_157{
                    text-align: left !important;
                }.tdi_157 .tdm-descr{
                    color: #ffffff;
                
					font-family:Source Sans Pro !important;font-size:15px !important;line-height:21px !important;font-weight:400 !important;
				}
</style><p class="tdm-descr">&copy; 2021 IT World Canada. All Rights Reserved.</p></div></div></div><div class="vc_column tdi_159  wpb_column vc_column_container tdc-column td-pb-span6">
<style scoped>

/* custom css */
.tdi_159{
                    vertical-align: baseline;
                }.tdi_159 > .wpb_wrapper,
				.tdi_159 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_159 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_159 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_159 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
/* inline tdc_css att */

.tdi_159{
justify-content:flex-end !important;
text-align:right !important;
}

/* phone */
@media (max-width: 767px)
{
.tdi_159{
justify-content:center !important;
text-align:center !important;
}
}

</style><div class="wpb_wrapper"><div class="td_block_wrap td_block_list_menu tdi_160 td-pb-border-top td_block_template_9 widget"  data-td-block-uid="tdi_160" >
<style>

/* inline tdc_css att */

.tdi_160{
margin-bottom:0px !important;
padding-top:8px !important;
padding-bottom:8px !important;
}

/* desktop */ @media(min-width: 1141px) { .tdi_160 { 
display:inline-table !important;
} }

/* phone */
@media (max-width: 767px)
{
.tdi_160{
margin-left:16px !important;
justify-content:center !important;
text-align:center !important;
display:inline-table !important;
}
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.tdi_160{
display:inline-table !important;
}
}

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px)
{
.tdi_160{
display:inline-table !important;
}
}

</style>
<style>
/* custom css */
.td_block_list_menu ul{
                  flex-wrap: wrap;
                  margin-left: 12px;
                }.td_block_list_menu ul li{
                  margin-left: 0;
                }.td_block_list_menu .sub-menu{
                  padding-left: 22px;
                }.td_block_list_menu .sub-menu li{
                  font-size: 13px;
                }.tdi_160 li{
					display: inline-block;
				
					font-family:Source Sans Pro !important;font-size:14px !important;line-height:1.6 !important;font-weight:400 !important;
				}.tdi_160 .menu{
					display: flex;
				}.tdi_160 .sub-menu{
					display: none;
				}.tdi_160 ul{
					margin: 0px;
				
					text-align: left;
					justify-content: flex-start;
				}.tdi_160 ul li{
					margin-right: 16px;
				}.tdi_160 ul li:last-child{
					margin-right: 0;
				}.tdi_160 a{
					color: #ffffff;
				}.tdi_160 a:hover{
					color: #000000;
				}
</style><div class="td-block-title-wrap"></div><div id=tdi_160 class="td_block_inner td-fix-index"><div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-101232" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-101232"><a href="http://www.itwc.ca/about-us.php">About Us</a></li>
<li id="menu-item-101233" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-101233"><a href="http://www.itwc.ca/contact-us.php">Contact Us</a></li>
<li id="menu-item-101234" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-101234"><a href="http://www.itwc.ca/legal.php">Privacy Policy</a></li>
<li id="menu-item-60962" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60962"><a href="https://www.itworldcanada.com/events">ITWC Events</a></li>
</ul></div></div></div></div></div></div></div><div id="tdi_161" class="tdc-row stretch_row"><div class="vc_row tdi_162  wpb_row td-pb-row tdc-element-style tdc-row-content-vert-center" >
<style scoped>

/* custom css */
.tdi_162,
                .tdi_162 .tdc-columns{
                    min-height: 0;
                }.tdi_162,
				.tdi_162 .tdc-columns{
				    display: block;
				}.tdi_162 .tdc-columns{
				    width: 100%;
				}@media (min-width: 767px) {
                    .tdi_162.tdc-row-content-vert-center,
                    .tdi_162.tdc-row-content-vert-center .tdc-columns {
                        display: flex;
                        align-items: center;
                        flex: 1;
                    }
                    .tdi_162.tdc-row-content-vert-bottom,
                    .tdi_162.tdc-row-content-vert-bottom .tdc-columns {
                        display: flex;
                        align-items: flex-end;
                        flex: 1;
                    }
                    .tdi_162.tdc-row-content-vert-center .td_block_wrap {
                        vertical-align: middle;
                    }
                    .tdi_162.tdc-row-content-vert-bottom .td_block_wrap {
                        vertical-align: bottom;
                    }
                }
/* inline tdc_css att */

.tdi_162{
position:relative;
}

.tdi_162 .td_block_wrap{ text-align:left }

</style>
<div class="tdi_161_rand_style td-element-style" ><style>
.tdi_161_rand_style{
background-color:#ffffff !important;
}
 </style></div><div class="vc_column tdi_164  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_164{
                    vertical-align: baseline;
                }.tdi_164 > .wpb_wrapper,
				.tdi_164 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_164 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_164 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_164 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="wpb_wrapper wpb_text_column td_block_wrap td_block_wrap vc_column_text tdi_165  tagdiv-type td-pb-border-top td_block_template_9"  data-td-block-uid="tdi_165" >
<style>

/* inline tdc_css att */

.tdi_165{
margin-bottom:0px !important;
padding-top:20px !important;
padding-bottom:0px !important;
}

</style>
<style>
/* custom css */
.tdi_165,
                .tdi_165 p{
			        font-family:Source Sans Pro !important;font-weight:400 !important;
		        }
</style><div class="td-block-title-wrap"></div><div class="td-fix-index"><p style="text-align: center;">Produced by <a href="https://itwc.ca/">ITWC</a> publishers of <a href="https://channeldailynews.com/">ChannelDailyNews.com</a>, <a href="https://www.itbusiness.ca/">ITbusiness.ca</a> and <a href="https://www.directioninformatique.com/">DirectionInformatique.com</a></p>
</div></div></div></div></div></div></div></div>        </div>

    </div>
    
</div><!--close td-outer-wrap-->



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5NVWMFZ"
height="0" width="0" style="display:none;visibility:hidden" aria-hidden="true"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

    <!-- <script src="//ajax.googleapis.com/ajax/libs/jquery/1.8.2/jquery.min.js" defer></script>-->
<script>
(function (i,s,o,g,a){
    try{
        var d=s.head||s.getElementsByTagName("head")[0]||s.documentElement,a=s.createElement(o);
        a.async=!0;
        a.charset="utf-8";
        a.type="text/javascript";
        a.src=g;    
        d.insertBefore(a,d.firstChild)
    }catch(e){}
})(window,document,'script','https://bb.itwc.ca/js/cube.js');
var api_key="704ec8ae80e05ea94654f6a86679303b";
var api_user="itwc";
// If this is an article page pass the Post ID and Slug
bb_post_id="469537";
bb_slug="apache-issues-fifth-patch-this-month-to-close-another-bug-in-log4j";
</script> 
                <div class="td-more-articles-box">
                    <i class="td-icon-close td-close-more-articles-box"></i>
                    <span class="td-more-articles-box-title">Recommended for you</span>
                    <div class="td-content-more-articles-box">

                    
        <div class="td_module_3 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.itworldcanada.com/article/why-cisos-have-to-consolidate-security-tools/381600" rel="bookmark" class="td-image-wrap " title="Why CISOs have to consolidate security tools" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAADrAQMAAAArGX0KAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7pzbEXmAAAAAAAAAAAACQHSaOAAGSp1GBAAAAAElFTkSuQmCC" alt="Sidebar: Workload automation tools" title="Why CISOs have to consolidate security tools" data-type="image_tag" data-img-url="https://i.itworldcanada.com/wp-content/uploads/2014/09/FEATURE-tools-SHUTTERSTOCK-324x235.jpg" data-img-retina-url="https://i.itworldcanada.com/wp-content/uploads/2014/09/FEATURE-tools-SHUTTERSTOCK.jpg" width="324" height="235" /></a></div>                <a href="https://www.itworldcanada.com/category/leadership" class="td-post-category">Leadership</a>            </div>
            <h3 class="entry-title td-module-title"><a href="https://www.itworldcanada.com/article/why-cisos-have-to-consolidate-security-tools/381600" rel="bookmark" title="Why CISOs have to consolidate security tools">Why CISOs have to consolidate security tools</a></h3>

            <div class="td-module-meta-info">
                <span class="td-post-author-name"><a href="https://www.itworldcanada.com/author/howardsolomon">Howard Solomon</a> <span>-</span> </span>                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-03-14T09:57:09-04:00" >March 14, 2016</time></span>                <span class="td-module-comments"><a href="https://www.itworldcanada.com/article/why-cisos-have-to-consolidate-security-tools/381600#respond">0</a></span>            </div>

            
        </div>

                            </div>
                </div>

    <!--

        Theme: Newspaper by tagDiv.com 2021
        Version: 11.3.2 (rara)
        Deploy mode: deploy
        
        uid: 61cce97ce2c7b
    -->

    
<!-- Custom css from theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
.td-more-articles-box .td-module-meta-info {display:none;}
.td-more-articles-box .td-module-title {line-height:30px;}
.fixphotos .td-author-photo img{border-radius: 50%; width:30px; height:30px; border:1px solid #ccc;}
.author-box-wrap img.photo {float:left;}
.article-caption-image img {display:none;}
@media (max-width:1000px) {
    .subframe{height:450px;}
}
@media (max-width:700px) {
    .subframe{height:520px;}
}
@media (max-width:600px) {
    .subframe{height:600px;}
}
@media (max-width:400px) {
    .subframe{height:800px;}
}
.podcast-author .tdb-author-photo {margin-right:10px;}
.tdb-author-counters {display:none;}
#relatedPosts { padding:5px 10px 5px 15px; border-left:5px solid #000; } 

#relatedPosts strong {display:block; padding-bottom:0px; color:#000;  margin-bottom:0px;  }
#relatedPosts a {text-decoration:underline;}



li.nav-search a {
  visibility: hidden;
}
li.nav-search a:before {
  content:'\e80a'; 
  visibility: visible;
  font-family: 'newspaper';
}
.td-video-template-bg {
    margin-top: 20px;}
</style>

<script type="text/javascript">var algolia = {"debug":false,"application_id":"F6VK5MWS9P","search_api_key":"ee1f3b8461d1895c8520cd6193318887","powered_by_enabled":false,"query":"","autocomplete":{"sources":[{"index_id":"posts_post","index_name":"wp_posts_post","label":"Posts","admin_name":"Posts","position":3,"max_suggestions":3,"tmpl_suggestion":"autocomplete-post-suggestion","enabled":true},{"index_id":"posts_cdn_blog","index_name":"wp_posts_cdn_blog","label":"Blogs","admin_name":"Blogs","position":5,"max_suggestions":2,"tmpl_suggestion":"autocomplete-post-suggestion","enabled":true},{"index_id":"posts_cdn_video","index_name":"wp_posts_cdn_video","label":"Videos","admin_name":"Videos","position":6,"max_suggestions":2,"tmpl_suggestion":"autocomplete-post-suggestion","enabled":true},{"index_id":"posts_cdn_slideshows","index_name":"wp_posts_cdn_slideshows","label":"Slideshows","admin_name":"Slideshows","position":8,"max_suggestions":2,"tmpl_suggestion":"autocomplete-post-suggestion","enabled":true},{"index_id":"users","index_name":"wp_users","label":"Authors","admin_name":"Users","position":22,"max_suggestions":1,"tmpl_suggestion":"autocomplete-user-suggestion","enabled":true}],"input_selector":"input[name='s']:not('.no-autocomplete')"},"indices":{"searchable_posts":{"name":"wp_searchable_posts","id":"searchable_posts","enabled":true,"replicas":[]},"posts_post":{"name":"wp_posts_post","id":"posts_post","enabled":true,"replicas":[]},"posts_cdn_slideshows":{"name":"wp_posts_cdn_slideshows","id":"posts_cdn_slideshows","enabled":true,"replicas":[]},"posts_cdn_blog":{"name":"wp_posts_cdn_blog","id":"posts_cdn_blog","enabled":true,"replicas":[]},"posts_cdn_video":{"name":"wp_posts_cdn_video","id":"posts_cdn_video","enabled":true,"replicas":[]},"users":{"name":"wp_users","id":"users","enabled":true,"replicas":[]}}};</script>
<script type="text/html" id="tmpl-autocomplete-header">
	<div class="autocomplete-header">
		<div class="autocomplete-header-title">{{{ data.label }}}</div>
		<div class="clear"></div>
	</div>
</script>

<script type="text/html" id="tmpl-autocomplete-post-suggestion">
	<a class="suggestion-link" href="{{ data.permalink }}" title="{{ data.post_title }}">
		<# if ( data.images.thumbnail ) { #>
			<img class="suggestion-post-thumbnail" src="{{ data.images.thumbnail.url }}" alt="{{ data.post_title }}">
		<# } #>
		<div class="suggestion-post-attributes">
			<span class="suggestion-post-title">{{{ data._highlightResult.post_title.value }}}</span>
			<# if ( data._snippetResult['content'] ) { #>
				<span class="suggestion-post-content">{{{ data._snippetResult['content'].value }}}</span>
			<# } #>
		</div>
	</a>
</script>

<script type="text/html" id="tmpl-autocomplete-term-suggestion">
	<a class="suggestion-link" href="{{ data.permalink }}" title="{{ data.name }}">
		<svg viewBox="0 0 21 21" width="21" height="21">
			<svg width="21" height="21" viewBox="0 0 21 21">
				<path
					d="M4.662 8.72l-1.23 1.23c-.682.682-.68 1.792.004 2.477l5.135 5.135c.7.693 1.8.688 2.48.005l1.23-1.23 5.35-5.346c.31-.31.54-.92.51-1.36l-.32-4.29c-.09-1.09-1.05-2.06-2.15-2.14l-4.3-.33c-.43-.03-1.05.2-1.36.51l-.79.8-2.27 2.28-2.28 2.27zm9.826-.98c.69 0 1.25-.56 1.25-1.25s-.56-1.25-1.25-1.25-1.25.56-1.25 1.25.56 1.25 1.25 1.25z"
					fill-rule="evenodd"></path>
			</svg>
		</svg>
		<span class="suggestion-post-title">{{{ data._highlightResult.name.value }}}</span>
	</a>
</script>

<script type="text/html" id="tmpl-autocomplete-user-suggestion">
	<a class="suggestion-link user-suggestion-link" href="{{ data.posts_url }}" title="{{ data.display_name }}">
		<# if ( data.avatar_url ) { #>
			<img class="suggestion-user-thumbnail" src="{{ data.avatar_url }}" alt="{{ data.display_name }}">
		<# } #>
		<span class="suggestion-post-title">{{{ data._highlightResult.display_name.value }}}</span>
	</a>
</script>

<script type="text/html" id="tmpl-autocomplete-footer">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</script>

<script type="text/html" id="tmpl-autocomplete-empty">
	<div class="autocomplete-empty">
		No results matched your query 		<span class="empty-query">"{{ data.query }}"</span>
	</div>
</script>

<script type="text/javascript">
	jQuery( function () {
		/* Initialize Algolia client */
		var client = algoliasearch( algolia.application_id, algolia.search_api_key );

		/**
		 * Algolia hits source method.
		 *
		 * This method defines a custom source to use with autocomplete.js.
		 *
		 * @param object $index Algolia index object.
		 * @param object $params Options object to use in search.
		 */
		var algoliaHitsSource = function( index, params ) {
			return function( query, callback ) {
				index
					.search( query, params )
					.then( function( response ) {
						callback( response.hits, response );
					})
					.catch( function( error ) {
						callback( [] );
					});
			}
		}

		/* Setup autocomplete.js sources */
		var sources = [];
		jQuery.each( algolia.autocomplete.sources, function ( i, config ) {
			var suggestion_template = wp.template( config[ 'tmpl_suggestion' ] );
			sources.push( {
				source: algoliaHitsSource( client.initIndex( config[ 'index_name' ] ), {
					hitsPerPage: config[ 'max_suggestions' ],
					attributesToSnippet: [
						'content:10'
					],
					highlightPreTag: '__ais-highlight__',
					highlightPostTag: '__/ais-highlight__'
				} ),
				templates: {
					header: function () {
						return wp.template( 'autocomplete-header' )( {
							label: _.escape( config[ 'label' ] )
						} );
					},
					suggestion: function ( hit ) {
						if ( hit.escaped === true ) {
							return suggestion_template( hit );
						}
						hit.escaped = true;

						for ( var key in hit._highlightResult ) {
							/* We do not deal with arrays. */
							if ( typeof hit._highlightResult[ key ].value !== 'string' ) {
								continue;
							}
							hit._highlightResult[ key ].value = _.escape( hit._highlightResult[ key ].value );
							hit._highlightResult[ key ].value = hit._highlightResult[ key ].value.replace( /__ais-highlight__/g, '<em>' ).replace( /__\/ais-highlight__/g, '</em>' );
						}

						for ( var key in hit._snippetResult ) {
							/* We do not deal with arrays. */
							if ( typeof hit._snippetResult[ key ].value !== 'string' ) {
								continue;
							}

							hit._snippetResult[ key ].value = _.escape( hit._snippetResult[ key ].value );
							hit._snippetResult[ key ].value = hit._snippetResult[ key ].value.replace( /__ais-highlight__/g, '<em>' ).replace( /__\/ais-highlight__/g, '</em>' );
						}

						return suggestion_template( hit );
					}
				}
			} );

		} );

		/* Setup dropdown menus */
		jQuery( algolia.autocomplete.input_selector ).each( function ( i ) {
			var $searchInput = jQuery( this );

			var config = {
				debug: algolia.debug,
				hint: false,
				openOnFocus: true,
				appendTo: 'body',
				templates: {
					empty: wp.template( 'autocomplete-empty' )
				}
			};

			if ( algolia.powered_by_enabled ) {
				config.templates.footer = wp.template( 'autocomplete-footer' );
			}

			/* Instantiate autocomplete.js */
			var autocomplete = algoliaAutocomplete( $searchInput[ 0 ], config, sources )
				.on( 'autocomplete:selected', function ( e, suggestion ) {
					/* Redirect the user when we detect a suggestion selection. */
					window.location.href = suggestion.permalink;
				} );

			/* Force the dropdown to be re-drawn on scroll to handle fixed containers. */
			jQuery( window ).on( 'scroll', function() {
				if ( autocomplete.autocomplete.getWrapper().style.display === "block" ) {
					autocomplete.autocomplete.close();
					autocomplete.autocomplete.open();
				}
			} );
		} );

		jQuery( document ).on( "click", ".algolia-powered-by-link", function ( e ) {
			e.preventDefault();
			window.location = "https://www.algolia.com/?utm_source=WordPress&utm_medium=extension&utm_content=" + window.location.hostname + "&utm_campaign=poweredby";
		} );
	} );
</script>
<script type='text/javascript' src='https://www.itworldcanada.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.14.1' id='gtm4wp-form-move-tracker-js'></script>
<script type='text/javascript' id='wp-ulike-pro-js-extra'>
/* <![CDATA[ */
var UlikeProCommonConfig = {"AjaxUrl":"https:\/\/www.itworldcanada.com\/wp-admin\/admin-ajax.php","Nonce":"6f58fbd477","TabSide":"top"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.itworldcanada.com/wp-content/plugins/wp-ulike-pro/public/assets/js/wp-ulike-pro.min.js?ver=1.7.5' id='wp-ulike-pro-js'></script>
<script type='text/javascript' src='https://www.itworldcanada.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js'></script>
<script type='text/javascript' src='https://www.itworldcanada.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=2713a088559ff26084e8003394764364' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://www.itworldcanada.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=11.3.2' id='td-site-min-js'></script>
<script type='text/javascript' id='wp-util-js-extra'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.itworldcanada.com/wp-includes/js/wp-util.min.js?ver=5.8.2' id='wp-util-js'></script>
<script type='text/javascript' src='https://www.itworldcanada.com/wp-content/plugins/wp-search-with-algolia/js/algoliasearch/dist/algoliasearch-lite.umd.js?ver=2.1.0' id='algolia-search-js'></script>
<script type='text/javascript' src='https://www.itworldcanada.com/wp-content/plugins/wp-search-with-algolia/js/autocomplete.js/dist/autocomplete.min.js?ver=2.1.0' id='algolia-autocomplete-js'></script>
<script type='text/javascript' src='https://www.itworldcanada.com/wp-content/plugins/wp-search-with-algolia/js/autocomplete-noconflict.js?ver=2.1.0' id='algolia-autocomplete-noconflict-js'></script>
<script type='text/javascript' src='https://www.itworldcanada.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=2713a088559ff26084e8003394764364' id='tdb_js_files_for_front-js'></script>
<script type='text/javascript' src='https://www.itworldcanada.com/wp-includes/js/wp-embed.min.js?ver=5.8.2' id='wp-embed-js'></script>

<!-- JS generated by theme -->

<script>
    

            
                jQuery().ready(function () {

                    var blockClass = '.tdi_32';

                    jQuery(blockClass + '.tdb-horiz-menu-singleline > .menu-item-has-children a').click(function (e) {
                        e.preventDefault();
                    })

                });
            
            

            
                /* global jQuery:{} */
                jQuery().ready(function () {

                    var tdbMenuItem = new tdbMenu.item();
                    tdbMenuItem.blockUid = 'tdi_43';
                    tdbMenuItem.jqueryObj = jQuery('.tdi_43');

	                
                    tdbMenuItem.isMegaMenuFull = true;

	                
	                
	                
                    tdbMenu.addItem(tdbMenuItem);

                });
            
            

            
                jQuery(window).on( 'load', function () {
                    var block = jQuery('.tdi_84'),
                        blockClass = '.tdi_84',
                        blockInner = block.find('.tdb-block-inner'),
                        blockOffsetLeft;

                    if( block.find('audio').length > 0 ) {
                        jQuery(blockClass + ' audio').mediaelementplayer();
                    }

                    if( block.hasClass('tdb-sfi-stretch') ) {
                        jQuery(window).resize(function () {
                            blockOffsetLeft = block.offset().left;

                            if( block.hasClass('tdb-sfi-stretch-left') ) {
                                blockInner.css('margin-left', -blockOffsetLeft + 'px');
                            } else {
                                blockInner.css('margin-right', -(jQuery(window).width() - (blockOffsetLeft + block.outerWidth())) + 'px');
                            }
                        });
                        jQuery(window).resize();
                    }

                    setTimeout(function () {
                        block.css('opacity', 1);
                    }, 500);
                });
            
            

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[469537]");
                });
            
</script>


</body>
</html>
<!-- Dynamic page generated in 0.613 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2021-12-29 18:04:28 -->

<!-- Super Cache dynamic page detected but late init not set. See the readme.txt for further details. -->
<!-- Dynamic Super Cache -->