Flaws flagged in OpenSSH

A pair of security vulnerabilities in a suite of tools used to send encrypted traffic to servers could let attackers run code on affected servers or cause denial-of-service attacks.

The flaws exist in OpenSSH, which replaces programs such as Telnet and FTP with secure versions, granting users an encrypted means of communicating with servers. The vulnerabilities affect OpenSSH Versions 2.3.1p1 through 3.3, according to an advisory from CERT Coordination Center. The flaws are in two types of authentication modules. An affected version of the software ships with the OpenBSD operating system. Users also might have downloaded and installed affected versions for other platforms. Users should upgrade to OpenSSH 3.4 or apply the patch available.